Per-site whitelist/blacklist for media.autoplay.enabled preference

RESOLVED DUPLICATE of bug 1376321

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 1376321
3 years ago
3 months ago

People

(Reporter: tramspap, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I'd like to prevent autoplaying videos in general (much easier now thanks to bug 659285 being fixed), but allow it on selected sites that use autoplay in ways I don't find annoying.

This was also requested in some of the comments on bug 659285:
https://bugzilla.mozilla.org/show_bug.cgi?id=659285#c77
https://bugzilla.mozilla.org/show_bug.cgi?id=659285#c94
This sounds like a front-end issue.
Component: Audio/Video → General
Product: Core → Firefox
Or a good idea of an add-on.

Comment 3

3 years ago
It would be nice if this could be implemented just like the way the whitelist is implemented for Flash.

Comment 4

3 years ago
Annoyed, me too, I disabled it. Sadly, at the same time, my alarm on 127.0.0.1 stopped working...

My two cents is to add a "per site" Autoplay Permission in each site information panel. At the same time, we should maybe convert the media.autoplay.enabled setting into something like permission.default.autoplay instead. What do you think? Thanks.

Comment 5

a year ago
I see many bugs of media.autoplay.enabled preference on this component.
Component: General → Audio/Video: Playback
Product: Firefox → Core

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1376321
You need to log in before you can comment on or make changes to this bug.