Closed Bug 1215950 Opened 4 years ago Closed 4 years ago

Crash on Google 2-step verification

Categories

(Firefox for Android :: General, defect, critical)

44 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 44
Tracking Status
firefox42 --- verified
firefox43 --- verified
firefox44 --- verified
fennec 42+ ---

People

(Reporter: mattcoz, Assigned: sebastian)

References

Details

(Keywords: crash, crashreportid, reproducible)

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151016030228

Steps to reproduce:

Go to google.com
Click sign in
Enter email address
Enter password
Get to 2-step verification page


Actual results:

Crash
OS: Unspecified → Android
Hardware: Unspecified → ARM
tracking-fennec: --- → ?
Please post some URLs of these crashlog reports from about:crashes
Flags: needinfo?(mattcoz)
Crash Signature: [@ android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views. at android.view.ViewRootImpl.checkThread(ViewRootImpl.java) ]
Keywords: crash, crashreportid
See Also: → 877090
I can reproduce the crash everytime with the steps provided on latest Nightly (2015-10-21) using Prestigio PSP5508 (Android 4.4.2)
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible
Version: Trunk → Firefox 44
Assignee: nobody → s.kaspari
tracking-fennec: ? → 42+
Background: This is a regression from the Android 6.0 keyboard workaround (bug 1211848). The crash reports are from Android 6.0 too - that's good. I'm surprised that Teodora can reproduce the crash on an Android 4.4.2 device. I wonder if without the crash the keyboard would not show up too (That's what the workaround fixed).

As mentioned in the duplicate (bug 1216563) I'm going to push the re-focus workaround code to the UI thread.
Attachment #8677592 - Flags: review?(nchen) → review+
Comment on attachment 8677592 [details] [diff] [review]
1215950-refocus-on-ui-thread.patch

Approval Request Comment

[Feature/regressing bug #]: Regression introduced by bug bug 1216563. Patch in bug 1216563 fixed an issue with the keyboard not showing up on Android 6.0 devices. This fix can lead to a crash. The patch has been uplifted to Aurora (43) and Beta (42).

[User impact if declined]: Potential crash on Android 6 if keyboard should come up.

[Describe test coverage new/current, TreeHerder]: Tested locally on different devices (Android 6, Android 5, Android 2.3).

[Risks and why]: Code logic has not been changed. Instead workaround code is now running on the UI thread (preventing crash on non-UI thread).

[String/UUID change made/needed]: -
Attachment #8677592 - Flags: approval-mozilla-beta?
Attachment #8677592 - Flags: approval-mozilla-aurora?
Sebastian, you haven't really answered to the risk question.
Could you explain if it is a risky change or not. Threading changes in beta 10 scare me.
Flags: needinfo?(s.kaspari)
By the way, the bug in "[Feature/regressing bug #]" is incorrect. This is the duplicate.
(In reply to Sylvestre Ledru [:sylvestre] from comment #9)
> Sebastian, you haven't really answered to the risk question.
> Could you explain if it is a risky change or not. Threading changes in beta
> 10 scare me.

I consider it low risk. The normal code flow remains the same. The workaround code is now pushed to the UI thread. This crash is happening because it is not running on the UI thread (it's touching views).

(In reply to Sylvestre Ledru [:sylvestre] from comment #10)
> By the way, the bug in "[Feature/regressing bug #]" is incorrect. This is
> the duplicate.

Oh, sorry. The bug is: bug 1211848 - That's where the regression / this crash has been introduced.
Flags: needinfo?(s.kaspari) → needinfo?(sledru)
Blocks: 1211848
Flags: needinfo?(sledru)
Comment on attachment 8677592 [details] [diff] [review]
1215950-refocus-on-ui-thread.patch

OK, Android 6.0 is going more and more popular during the next 6 weeks.
Taking it avoid having do to a dot release. Should be in 42 beta 10.
Attachment #8677592 - Flags: approval-mozilla-beta?
Attachment #8677592 - Flags: approval-mozilla-beta+
Attachment #8677592 - Flags: approval-mozilla-aurora?
Attachment #8677592 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/6c5f530312e3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
I can't reproduce the crash with the steps provided on latest Nightly (2015-10-26) using Prestigio PSP5508 (Android 4.4.2)
I can also confirm that it is working for me now.
Verified as fixed in Firefox 42 Beta 10;
Device: Asus Transformer Pad (Android 4.2.1).
Verified as fixed on Firefox 43.0a2 (2015-10-27)
Device: Prestigio PSP5508 (Android 4.4.2)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.