[Fetch] After disconnecting from network, fetch requests still receive status 200 response for ~1 minute

RESOLVED DUPLICATE of bug 1120715

Status

()

defect
RESOLVED DUPLICATE of bug 1120715
4 years ago
4 years ago

People

(Reporter: TimAbraldes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

One of the Service Worker Cookbook recipes is exhibiting some seemingly unexplained behavior in both Firefox and Chrome. `fetch` calls at [1] are "succeeding" for about a minute after disconnecting from the network entirely. An issue was filed against the cookbook at [2].


[1] https://github.com/mozilla/serviceworker-cookbook/blob/master/cache-then-network/index.js#L128
[2] https://github.com/mozilla/serviceworker-cookbook/issues/16
NI bkelly per overholt's advice in #apps
Flags: needinfo?(bkelly)
Neither chrome nor Firefox implements the fetch() Cache parameters yet.  See bug 1120715.

If you add Cache busting query params to the URL, does the problem go away?
Flags: needinfo?(bkelly) → needinfo?(tabraldes)
(In reply to Ben Kelly [:bkelly] from comment #2)
> Neither chrome nor Firefox implements the fetch() Cache parameters yet.  See
> bug 1120715.
> 
> If you add Cache busting query params to the URL, does the problem go away?

Indeed that fixes the issue. Thanks!
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(tabraldes)
Resolution: --- → DUPLICATE
Duplicate of bug: 1120715
You need to log in before you can comment on or make changes to this bug.