Closed Bug 1216409 Opened 6 years ago Closed 6 years ago

Use string escape sequences in Emoji layout definition and ensure all BMP characters are followed by a VS16

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 993899

People

(Reporter: timdream, Assigned: timdream)

References

Details

Attachments

(3 files)

A VS16 appended after the code point ensure Gecko and other software renders the character in Emoji when the font is available. We need to ensure Keyboard app outputs that and also do so in it's own DOM.
Unfortunately the xpcshell used to build Gaia does not understand ES6 string escaping sequence (\u{xxxxx}) yet.
Summary: Use NCR in Emoji layout definition and ensure all U+26xx and U+27xx characters are followed by a VS16 → Use string escape sequences in Emoji layout definition and ensure all BMP characters are followed by a VS16
master: https://github.com/mozilla-b2g/gaia/commit/eca45a41ee722833ee95febdf8728287da7d1c82
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attached file convert-ncr.js
Here is the Node.js script to covert BMP Emojis to escape sequences (and append it with VS16). Please manually check the result before commit.
master revert: https://github.com/mozilla-b2g/gaia/commit/c661bff9095ce0a7744d98a1f41878d2f5820e73

Reza is going to apply this work on bug 993899 instead since the definition have changed quite a lot.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 993899
You need to log in before you can comment on or make changes to this bug.