Closed Bug 1216617 Opened 6 years ago Closed 6 years ago

[Messages] Disable timeout for ActivityClient

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+)

RESOLVED FIXED
blocking-b2g 2.5+

People

(Reporter: julienw, Assigned: azasypkin)

Details

(Keywords: regression, Whiteboard: [sms-sprint-FxOS-S9])

Attachments

(1 file)

I used a STR that is something like the following, but we can maybe make it simpler:

1. Receive a SMS.
2. Force-kill the app.
3. Dismiss the notification.
4. Start Gallery.
5. Share an image with Messages.

=> white screen.

Error in the logcat is:

10-20 18:16:08.947  4634  4634 E Messages: Content JS ERROR: Unable to establish a connection with "activity-service". Either the target endpoint is not alive or the Service is not `.listen()`ing. 
10-20 18:16:08.947  4634  4634 E Messages:     at [2]</Client.prototype.connect/this.connected< (app://sms.gaiamobile.org/lib/bridge/bridge.js:4:118)
Comms triage: Functionality broken.
blocking-b2g: 2.5? → 2.5+
Hey Julien, I can't reproduce the issue from my side. I'm using latest gaia and gecko with few weeks ago. Requesting QA support as well for more information.
Flags: needinfo?(felash)
Keywords: qawanted
I'm not reproducing anymore today either. Maybe I miss a step in the STR above...

I'm closing the bug and add a NI to Oleg who might know better how such an error can happen and come up with a better STR.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(felash) → needinfo?(azasypkin)
Resolution: --- → WORKSFORME
Flags: needinfo?(jmercado)
Keywords: qawanted
Flags: needinfo?(jmercado)
Yeah, I think it can easily happen under the pressure since default bridge timeout is quite small for the heavy load - 1000ms. To confirm I've just tried the following STR:

* Open Messages app with heavy workload;
* Switch to Gallery right away and try to share _big_ image (I was trying to share 9MB image);

In this case we'll be definitely hit by timeout on Flame, likely not on Aries. So I think we should just disable timeout for the ActivityClient for v2.5 (will check if it's possible to emulate in integration tests). Later I still want the bridge to log _slow_ responses so that we know what is going on when analyzing such bugs via logcat.

Julien, does it sound similar to what you were experiencing?
Assignee: nobody → azasypkin
Status: RESOLVED → REOPENED
Flags: needinfo?(azasypkin) → needinfo?(felash)
Resolution: WORKSFORME → ---
Summary: [Messages] We get a white screen in some situations, when sharing from gallery → [Messages] Disable timeout for ActivityClient
Yeah this looks like it, maybe when I tried to reproduce I tried on Aries instead of Flame or used a smaller workload.
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #5)
> Yeah this looks like it, maybe when I tried to reproduce I tried on Aries
> instead of Flame or used a smaller workload.

Okay, will fix it. So to be more precise - the size of the image doesn't really matter, the main thing is that two apps are competing for the resources and I can't reliably replicate this on b2g simulator obviously :/
Status: REOPENED → ASSIGNED
Attachment #8678083 - Flags: review?(felash)
Comment on attachment 8678083 [details] [review]
[gaia] azasypkin:bug-1216617-disable-activity-client-timeout > mozilla-b2g:master

This fixes the issue for me.

r=me !
Attachment #8678083 - Flags: review?(felash) → review+
Thanks for quick review!

Master: https://github.com/mozilla-b2g/gaia/commit/bca58da77ce14a38692af58f62375e3b3d97febf
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [sms-sprint-FxOS-S9]
You need to log in before you can comment on or make changes to this bug.