Command shortcuts fail when using a custom keymap on MacOS

RESOLVED DUPLICATE of bug 1333781

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 1333781
2 years ago
a month ago

People

(Reporter: Jolyon Ralph, Unassigned)

Tracking

41 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36

Steps to reproduce:

Created a custom keymap using the Ukelele application to add the # key for simpler use on UK keyboard.

Installed keymap using application and selected keymap from Mac Keyboard settings.


Actual results:

Works perfectly with all applications except Firefox (and other XUL apps) where cmd key operations such as Cmd-F fail to work. 




Expected results:

Cmd-F should work as expected regardless of the keymap installed.

Note that this bug has also been discussed (five years ago!) on the Ukelele forum:

https://groups.google.com/forum/#!searchin/ukelele-users/firefox/ukelele-users/XJdF-EoYtIc/lpIT3dwGgxMJ

Updated

2 years ago
Component: Untriaged → Keyboard Navigation
OS: Unspecified → Mac OS X

Updated

a month ago
Duplicate of this bug: 1381952
This has been partially fixed in bug 429824. The remaining work is covered by bug 1333781.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333781
You need to log in before you can comment on or make changes to this bug.