Last Comment Bug 1216677 - pulse_actions: Clear builders cache when there are issues
: pulse_actions: Clear builders cache when there are issues
Status: RESOLVED FIXED
:
Product: Testing
Classification: Components
Component: General (show other bugs)
: unspecified
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4)
:
:
Mentors:
: 1210390 (view as bug list)
Depends on:
Blocks: 1180732
  Show dependency treegraph
 
Reported: 2015-10-20 11:27 PDT by Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4)
Modified: 2015-10-27 13:27 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4) 2015-10-20 11:27:20 PDT
The issues arises after a reconfig which changes the list of builders and it clears once the Heroku's dynos restart the next day.

This will come out of a fix in mozci:
https://github.com/mozilla/mozilla_ci_tools/issues/365
Comment 1 User image Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4) 2015-10-23 07:52:11 PDT
*** Bug 1210390 has been marked as a duplicate of this bug. ***
Comment 2 User image Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4) 2015-10-23 07:52:26 PDT
*** Bug 1212002 has been marked as a duplicate of this bug. ***
Comment 3 User image Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4) 2015-10-23 07:56:20 PDT
Let's assume for automatic backfilling that allthethings.json will always be out of date.
It gets generated every 15 minutes on the clock and the new file becomes public once an hour on the 10th minute.
That means that automatic backfilling will start hearing about new builders before we can actually determine if they're valid or not.

If we hear about a builder, we will *not* verify it and carry on. This might be an issue with a builder being removed by the time we try to schedule it. In that case, we should recover by catching the error from Buildapi.
Comment 4 User image Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4) 2015-10-27 13:27:09 PDT
I believe this is not anymore an issue after disabling verifications.
https://github.com/mozilla/pulse_actions/blob/master/pulse_actions/worker.py#L191

Note You need to log in before you can comment on or make changes to this bug.