NSS3.4 Cannot remmber 2 web certs from same server, different ports

VERIFIED FIXED in psm2.2

Status

P1
normal
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: junruh, Assigned: ssaux)

Tracking

1.0 Branch
psm2.2
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
1.) Visit https://pki.mcom.com:5002
2.) Remember the web site cert.
3.) Visit https://pki.mcom.com/tests.html
4.) Try to remember the web site cert.
What happens: I start an endless loop, unless I click Cancel, twice.
(Assignee)

Updated

17 years ago
Blocks: 116334
Priority: -- → P1
Target Milestone: --- → 2.2
(Reporter)

Comment 1

17 years ago
*** Bug 121698 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Depends on: 122459
(Assignee)

Comment 2

17 years ago
Can't reproduce with kai 1/28 build.
Marking worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
Verified WFM.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

17 years ago
Reopening. Reproducible as originally described with the 2/8 Win2000 trunk 
build. Removing "NSS3.4" from summary.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Summary: NSS3.4 Cannot remmber 2 web certs from same server, different ports → Cannot remmber 2 web certs from same server, different ports
(Assignee)

Comment 5

17 years ago
updating summary to reflect that this is related to 3.4
Summary: Cannot remmber 2 web certs from same server, different ports → NSS3.4 Cannot remmber 2 web certs from same server, different ports
(Assignee)

Comment 6

17 years ago
I reproduced this. I didn't have an endless loop is I didn't try to remember the
second cert.

Comment 7

17 years ago
Good catch here. The problem is SEC_CERTNicknameConflict is always returning OK,
so PSM does not have a chance to choose a new nickname for the cert.

bob

Comment 8

17 years ago
Created attachment 69504 [details] [diff] [review]
Implement SEC_CERTNicknameConflict

Comment 9

17 years ago
Comment on attachment 69504 [details] [diff] [review]
Implement SEC_CERTNicknameConflict

r=wtc.
Attachment #69504 - Flags: review+
(Reporter)

Comment 10

17 years ago
nsbeta1
Keywords: nsbeta1
(Assignee)

Comment 11

17 years ago
This appears to be fixed in build id 2002022503
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
Verified fixed.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.2 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.