[css-grid] Percent widths on grid items are resolved against grid's full width, instead of grid area's width

VERIFIED DUPLICATE of bug 1163435

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 1163435
2 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox44 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8677129 [details]
testcase 1

STR:
 1. Load attached testcase, with grid enabled (layout.css.grid.enabled)

EXPECTED RESULTS:
In the testcase's lower section, the "b" cell should be slightly skinnier than in the upper section. (Its 75% width should make it occupy only 75% of its 50px-wide grid area.)

ACTUAL RESULTS:
In the testcase's second line, the "b" cell is *wider* than in the upper section. (It looks like it's taking 75% of the grid's full width)


Chrome 48 (w/ Experimental Web Platform Features enabled) gives EXPECTED RESULTS. Nightly 44.0a1 (2015-10-21) gives ACTUAL RESULTS.

(Mats, feel free to dupe as-needed if this is already tracked somewhere.)
(Reporter)

Updated

2 years ago
Flags: needinfo?(mats)
I think this is just because we haven't landed that code yet? (bug 1163435)

I was waiting for a CSSWG decision on the matter before landing it but that
never materialized.  I think the consensus now (at Mozilla) is that we
should ship what we believe is the right thing to do, which is to resolve
it against the size in the same axis, so I think we can land that patch
now because that what it does IIRC.  (the patch is probably bit-rotten
by now though)

(There's also a separate bug for abs.pos., bug 1163565.)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mats)
Resolution: --- → DUPLICATE
Duplicate of bug: 1163435
(Reporter)

Comment 2

2 years ago
Ah, thanks.
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.