PAC: ignores other proxies returned from FindProxyForURL

VERIFIED DUPLICATE of bug 84798

Status

()

Core
Networking
--
major
VERIFIED DUPLICATE of bug 84798
17 years ago
15 years ago

People

(Reporter: Xiaobin Lu, Assigned: neeti)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20011128
Netscape6/6.2.1
BuildID:    20010124

Mozilla ignores the rest of proxy information returned from FindProxyForURL. For
example, if FindProxyForURL returns "Proxy:xxx.com:8080; Proxy yyy.com:8080". If
xxx.com does not work, mozilla won't use yyy.com to complete the http
connection. This works for Netscape 4.78 and it is documented in Netscape
developer docs.

Reproducible: Always
Steps to Reproduce:
1. Write an autoconfig script file such as:
function FindProxyForURL(url, host)
{
return "Proxy:xxx.xom:8080; Proxy:yyy.com:8080"
}
2. Make xxx.com be an invalid proxy while yyy.com is the correct one
3.  Mozilla can not use yyy.com when xxx.com is failed.

Actual Results:  Mozilla fails to set up connection to any host.

Expected Results:  Mozilla should use yyy.com to be the proxy.
*** Bug 124087 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 84798 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
VERIFIED/dupe
Status: RESOLVED → VERIFIED
Summary: Mozilla ignores other proxies returned from FindProxyForURL → PAC: ignores other proxies returned from FindProxyForURL

Updated

15 years ago
QA Contact: benc → pacqa
You need to log in before you can comment on or make changes to this bug.