Fennec: Scroll progression (momentum) is inconsistent

RESOLVED WORKSFORME

Status

()

Firefox for Android
Graphics, Panning and Zooming
RESOLVED WORKSFORME
2 years ago
7 months ago

People

(Reporter: avih, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [content perf])

Attachments

(1 attachment)

92.28 KB, application/x-zip-compressed
Details
(Reporter)

Description

2 years ago
The symptom is that after a swipe up/down, it sometimes looks like the progression slows down and speeds up without any further user input (beyond the gradual slow down due to "friction").

This happens on relatively complex pages more than on simple pages.

Expected result: If the content can't be scrolled at 60fps, then it should render at lower refresh rate, but the progression speed (distance/time) shouldn't be affected.

Test clip (shows visiting http://yahoo.com on both Fennec and Chrome) - notice the swipes from 00:21 to 00:26 and from 00:27 to 00:32: https://people.mozilla.org/~ahalachmi/share/content-perf/fennec-slow-fast-lowres-yahoo~2015-10-19.mp4

Chrome on android (the second half of the clip) doesn’t exhibit this behavior.

Tested using:
Fennec: Aurora 43.0a2 API11 2015-09-30
Chrome: 39.0.2171.93
(Reporter)

Updated

2 years ago
Blocks: 1213469

Comment 1

2 years ago
snorp, will this be fixed when native APZ lands?
Flags: needinfo?(snorp)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1133794

Comment 3

2 years ago
Created attachment 8677980 [details]
offline version of cmxlog.zip

Here is an offline copy of cmxlog you requested.

The online URL you can use which doesn't change is http://www.cmxlog.com/11/#
(Reporter)

Comment 4

2 years ago
(In reply to Grant from comment #3)
> Created attachment 8677980 [details]
> offline version of cmxlog.zip
> 
> Here is an offline copy of cmxlog you requested.

Not working for me as expected. After extracting the zip into a folder on an Android device, when I open the main page in Fennec (either while offline or while internet access is available), I don't get the mobile layout, and it doesn't really reproduce the issue while scrolling.

Did you try it and it worked for you? if yes, what are the exact steps you took to reproduce the issue with this zip?

> The online URL you can use which doesn't change is http://www.cmxlog.com/11/#

Just tried that, doesn't work for me - the page comes up quite empty and without the long list of log items, and the issue cannot be reproduced with it.


If you want to provide another attachment to reproduce it, please make sure first it works in the following scenario:

1. Disable internet access.
2. Clear the Fennec cache (settings -> privacy -> Clear now -> check only "Cache" -> Clear data)
3. open your test page in Fennec

--> The the scroll issue can be reproduced with this page.
(In reply to :Margaret Leibovic from comment #1)
> snorp, will this be fixed when native APZ lands?

That's hard to say without investigating why this is happening.
Flags: needinfo?(snorp)
It looks like yahoo.com has a neverending scrolling type of thing where it loads new content when you get near the end. I wonder if that's involved.
(Reporter)

Comment 7

a year ago
As the video at comment 0 demonstrates, this bug is not about scroll issues while content is being loaded. It's about inconsistent progression when it looks like nothing new is being loaded.
Now that Fennec has switched to APZ, do you still see this issue?
Flags: needinfo?(avihpit)
(Reporter)

Comment 9

7 months ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> Now that Fennec has switched to APZ, do you still see this issue?

I just tried with nightly from yesterday, and indeed I can't notice uneven progression as it was reported originally.

Can be RESOLVED-FIXED as far as I'm concerned.
Flags: needinfo?(avihpit)
Thanks!
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.