Performance: Slow File Dialog

VERIFIED DUPLICATE of bug 111821

Status

Core Graveyard
File Handling
--
minor
VERIFIED DUPLICATE of bug 111821
17 years ago
2 years ago

People

(Reporter: Ariel Gonzalez, Assigned: Bill Law)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2001-01-21-03, Win2k

The "file picking" dialogs for Save As and Open etc. are very slow when
displaying the contents of a folder. For example, try to Open a file in a folder
(or root drive) with lots of stuff in there... you can actually see the files
being "painted" in the dialog.

This is not too bad on my Celeron400, but if I there is a CPU-intensive
background task (such as rendering with POV-Ray), there is a VERY noticable
slowdown, and worse is that you can't click "Open" or "Save" until it is done
painting.

Comment 1

17 years ago
Probably INVALID?  The Open/Save dialogs for Windows platforms are just the
native versions, I think.  If so, that means Mozilla has no control over how
fast or slow they are.
(Reporter)

Comment 2

17 years ago
They might be the native versions, but for some reason they are slower than in
any other program open at the same time, for example the one's I am running
right now, which are Word, Notepad and Photoshop.

So maybe it's the way we are calling the dialog? Or maybe they are not really
native but they just look that way?
The dialogs are really honest-to-god native ones on Windows....

Over to XP apps.
Assignee: law → trudelle
Component: File Handling → XP Apps
(Reporter)

Comment 4

17 years ago
Sorry for the spam, but does anyone else see this, or is it just me? I mean,
maybe people with faster computers don't really notice it, but try loading some
CPU-intensive apps and compare the performance of the dialogs here and in other
apps. :)

Comment 5

17 years ago
This was already correctly assigned. ->file handling.  Bill, are we doing
anything that could possible slow these dialogs down?
Assignee: trudelle → law
Component: XP Apps → File Handling
(Assignee)

Comment 6

16 years ago
Nothing, directly.  I have, on occasion, witnessed this phenomenon.  Closing
Mozilla and restarting it clears things up.  It could be a Windows resource
problem caused elsewhere that just appears in the file dialog.

I certainly don't see it all the time, regardless of what activity is going on
in the background.  We need a way to reliably reproduce this effect before we
can do too much with this one.
Target Milestone: --- → Future

Comment 7

16 years ago
I can corroborate that the file open/save dialogs are slower with Mozilla than
other applications. It's not a sometimes thing, either, it's always slower. I've
experienced it on multiple machines, as well. Walking directories via the
open/save takes several times longer on Mozilla than, say, Internet Explorer.

Scrolling the window in a directory with many files is slow in the same way,
where you can watch it paint individual files or folders. Each one takes a
fraction of a second, but it adds up.

Seems like a memory issue. Perhaps other applications pre-cache files before
rendering?
(Reporter)

Comment 8

16 years ago
Just looking for an update on this. Are the file dialogs fully native or not?
The problem I have with this is that during high-CPU-usage situations,
downloading a file is very tedious because you can barely navigate the filesystem.

For an easy way of duplicating this, just start to encode an MP3 or something
and then save a file. That is enough to produce a noticable delay on my 400MHz
machine. If you need more challenge, start rendering something in POV-Ray and
encoding an OGG at the same time. Just anything to really tax the CPU.

During these conditions, the Mozilla save dialog will be pratically unusable,
but any other app (Word, notepad, explorer) will still respond.

*** This bug has been marked as a duplicate of 111821 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.