Configured Firefox Android device not listed on "Wi-fi devices" section of WebIDE

NEW
Unassigned

Status

()

Firefox
Developer Tools: about:debugging
P3
normal
2 years ago
3 months ago

People

(Reporter: jackson, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151022004116

Steps to reproduce:

With "Remote Debugging via WI-FI" enabled on android device (Firefox For Android Beta 42.0), on the same network as Firefox Developer Edition:

Open WebIDE.  Check webIDE right sidebar for device listed under "WI-FI Devices" section.


Actual results:

No WIFI devices are listed in WebIDE.


Expected results:

Android device should have appeared.  Note that I *HAVE* seen this working with the same device (probably Firefox for Android Beta 4.1? likely FF Developer Edition was 4.2 version at that time).

I do not see a way to re-scan for advertising wifi devices in WebIDE.  I will gladly provide more debugging info if instructed on where to get it.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Confirming with Nightly 44.0a1 on Desktop (20151023) and on Android 4.1.2 (20151015, updates seem to be turned off). Also experienced the issue last weekend with Aurora.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Debugger
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 43 Branch → Trunk
Component: Developer Tools: Debugger → Developer Tools: WebIDE
In 45, we exposed a refresh button which may help with part of this (bug 1210123).

Were you using the same WiFi network between the working and failing case?  Some WiFi routers don't work well with this feature (they need to support multicast packets correctly).
Flags: needinfo?(jacksonscottsly)
Blocks: 1142741
(Reporter)

Comment 3

2 years ago
@jryans: yes, I was on the same wifi network (I did put that in my steps-to-reproduce in the ticket).  With the wifi routers issue, would this be a problem intermittently if the router poorly supports multicast?  because I have had this feature working, at times, with both the routers I have tried (but when they both failed, I created this ticket).  However, I have not gotten it to work again since reporting this issue on any wifi network I have tried.
Flags: needinfo?(jacksonscottsly)
My almost 10 years old router supports multicast in its settings, but enabling these options didn't result in WiFi debugging success. Nightly's WebIDE still didn't show the Android and Firefox OS devices for which the debugging over WiFi had been enabled.
Component: Developer Tools: WebIDE → Developer Tools: about:debugging
Blocks: 1361763
About:debugging bug triage. Filter on TRIAGE-JD201705

Temporarily setting P3 to bugs migrated from webide to cleanup the triage for about:debugging.
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.