Closed Bug 1217754 Opened 4 years ago Closed 4 years ago

Fix uninitialized members of classes

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1217756
Tracking Status
firefox44 --- affected

People

(Reporter: baku, Assigned: baku)

References

Details

For bug 525063 I wrote a static analysis component that is able to detect uninitialized members in our source code. I file this bug to fix the existing issues I found.

Currently my code is not able to detect that mA and mB are correctly initialized here: |Foo::Foo() { mA = mB = 0; }| but we don't have so many of these cases and I prefer to rewrite them like this: |Foo::Foo() { mA = 0; mB = 0; }| or |Foo::Foo() : mA(0), mB(0) {}|.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1217756
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.