Closed Bug 1217827 Opened 4 years ago Closed 4 years ago

Enable MOZ_WEBRTC for Firefox OS on aarch64

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox45 fixed)

RESOLVED FIXED
FxOS-S10 (30Oct)
Tracking Status
firefox45 --- fixed

People

(Reporter: afarden, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
Attached patch Gecko Patch (obsolete) — Splinter Review
We need this or we hit this condition: https://github.com/mozilla/gecko-dev/blob/master/media/libvpx/moz.build#L67

Which is an error because `cpu-features.c` no longer exists.

Whatever it was originally used for is probably redundant, and can be removed as it was removed from the Android NDK 4 years ago.
Attachment #8678109 - Flags: review?(fabrice)
Comment on attachment 8678109 [details] [diff] [review]
Gecko Patch

Review of attachment 8678109 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me but you need a build peer review for changes to configure.in
Attachment #8678109 - Flags: review?(mh+mozilla)
Attachment #8678109 - Flags: review?(fabrice)
Attachment #8678109 - Flags: feedback+
Comment on attachment 8678109 [details] [diff] [review]
Gecko Patch

Review of attachment 8678109 [details] [diff] [review]:
-----------------------------------------------------------------

We don't put Signed-off-by lines in commit messages.

I'm tempted to say this is incomplete. That is, I don't see a reason not to enable webrtc on aarch64. But it isn't related to the specific reasons you are giving in the commit message. In fact, I'd argue you should actually fix the webrtc-disabled case as well.
Attachment #8678109 - Flags: review?(mh+mozilla) → review+
Actually I misinterpreted the error. Here it is in full:

    File listed in SOURCES does not exist: '/home/adfad666/B2G/gecko/home/adfad666/B2G/ndk/sources/android/cpufeatures/cpu-features.c'

The file _does_ exist, but the path is invalid.

I'll update the commit message and open a new bug for this.
Attached patch Gecko PatchSplinter Review
No change to patch, only updated the commit message.

Bug 1218702 created for NDK path bug.
Attachment #8678109 - Attachment is obsolete: true
Attachment #8679320 - Flags: review?(mh+mozilla)
Attachment #8679320 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/87939d690491
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S10 (30Oct)
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
You need to log in before you can comment on or make changes to this bug.