Unable to load cloudsovercuba.com/

RESOLVED DUPLICATE of bug 1071646

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1071646
2 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox41 affected, firefox42 affected, firefox43 affected, firefox44 affected)

Details

(Reporter)

Description

2 years ago
Reproducible with 42.0b9 (Build ID: 20151022152545), latest 43.0a2 and 44.0a1 (from 2015-10-22)
Affected platforms: Windows 7 x64, Windows 10 x64, Mac OS X 10.10.5 and Ubuntu 14.04 x86

Steps to reproduce:
1. Launch Firefox.
2. Navigate to http://cloudsovercuba.com/

Expected results: Page successfully loads.

Actual results: Page loading gets stuck at 50%.

Additional notes:
1. Also reproducible with 40.0.3 and with 39.0.3 build 2 the “The interactive documentary experience is not compatible with this version of Firefox. Download the latest version” message is displayed. Works with Chrome.
2. Browser console output:
'unreachable code after return statement' thrown by jfk.min.js:2:153831
'starting webaudio version' thrown by jfk.min.js:2:101847
'ReferenceError: g is not defined' thrown by jfk.min.js:2:109987
It seems this is because of the error "ReferenceError: g is not defined".

A reduced testcase:
> function func() {
>   if (true) {
>     var a = g;
>     function g() {}
>   }
> }

In this code, "g" is not defined when it is referenced with Gecko, while this code works fine with Blink and WebKit.

I don't know what ECMA spec says about the scope of function inside an "if" block, but this seems to be an issue related to JS anyway.
Component: Audio/Video: Playback → JavaScript Engine
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox43: --- → affected

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 585536
Duplicate of bug: 1071646
You need to log in before you can comment on or make changes to this bug.