Closed Bug 1217984 Opened 4 years ago Closed 2 years ago

"ASSERTION: bad index: 'aIndex >= 0 && aIndex < int32_t(mRows.Length())' & ASSERTION: bad row: 'aRow >= 0 && aRow < int32_t(mRows.Length())'"

Categories

(Core :: XUL, defect)

Unspecified
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox44 --- affected

People

(Reporter: RyanVM, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

+++ This bug was initially created as a clone of Bug #366203 +++

The testcase from bug 366203 still reliably hits the warning and asserts it was originally filed for on Android. However, desktop platforms are now unaffected.

WARNING: row count changed unexpectedly: 'mRowCount == rowCount', file /builds/slave/try-and-api-11-d-0000000000000/build/src/layout/xul/tree/nsTreeBodyFrame.cpp, line 2878
[731] ###!!! ASSERTION: bad index: 'aIndex >= 0 && aIndex < int32_t(mRows.Length())', file /builds/slave/try-and-api-11-d-0000000000000/build/src/layout/xul/tree/nsTreeContentView.cpp, line 224
[731] ###!!! ASSERTION: bad row: 'aRow >= 0 && aRow < int32_t(mRows.Length())', file /builds/slave/try-and-api-11-d-0000000000000/build/src/layout/xul/tree/nsTreeContentView.cpp, line 193
Looks like this in fact does hit intermittently on Linux/OSX as well.
https://hg.mozilla.org/integration/mozilla-inbound/rev/1988a43888ae
Keywords: leave-open
Summary: Android ASSERTION: bad index: 'aIndex >= 0 && aIndex < int32_t(mRows.Length())' & ASSERTION: bad row: 'aRow >= 0 && aRow < int32_t(mRows.Length())' → "ASSERTION: bad index: 'aIndex >= 0 && aIndex < int32_t(mRows.Length())' & ASSERTION: bad row: 'aRow >= 0 && aRow < int32_t(mRows.Length())'"
Has Regression Range: --- → irrelevant
Flags: needinfo?(ryanvm)
No longer asserts on trunk. Removing the assertion annotations.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(ryanvm) → in-testsuite+
Keywords: leave-open
Resolution: --- → WORKSFORME
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/aea1499376f7
Remove assertion annotations for 366203-1.xul. r=me
You need to log in before you can comment on or make changes to this bug.