Scroll+Cmd zooms even if scrolling gesture is finished at the time of Cmd key pressing

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
3 years ago
10 months ago

People

(Reporter: ojab, Unassigned)

Tracking

({steps-wanted})

43 Branch
Unspecified
Mac OS X
steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tpi:+][tpi-help-requested])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151023004026

Steps to reproduce:

1. Two finger scroll with a trackpad
2. While the scroll is still occurring, push ctrl.
3. The page zooms instead of continuing to scroll.


Actual results:

PDF is zoomed


Expected results:

PDF should not be zoomed
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
(Reporter)

Comment 1

3 years ago
There is bugs for linux https://bugzilla.mozilla.org/show_bug.cgi?id=649770 and windows https://bugzilla.mozilla.org/show_bug.cgi?id=1199737 citing the same issue, dunno if this bug should be a duplicate.

Comment 2

3 years ago

I can reproduce the bug on FF Nightly 44.0a1 (2015-10-26)

Bugs that are related to this one but are on different OS. 

linux:  https://bugzilla.mozilla.org/show_bug.cgi?id=1199737

windows: https://bugzilla.mozilla.org/show_bug.cgi?id=649770

On Chrome this bug can't be reproduce.
Status: UNCONFIRMED → NEW
Component: Untriaged → Panning and Zooming
Ever confirmed: true
Product: Firefox → Core
Component: Panning and Zooming → Widget: Cocoa
See Also: → bug 1199737, bug 649770
(In reply to ovidiu boca from comment #2)
> 
> I can reproduce the bug on FF Nightly 44.0a1 (2015-10-26)

Do you have steps to reproduce? The steps in comment 0 are not sufficient to reproduce this locally.
Keywords: steps-wanted
Whiteboard: [gfx-noted]

Comment 4

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #3)
> (In reply to ovidiu boca from comment #2)
> > 
> > I can reproduce the bug on FF Nightly 44.0a1 (2015-10-26)
> 
> Do you have steps to reproduce? The steps in comment 0 are not sufficient to
> reproduce this locally.

Hi Anthony, 

You need to reproduce this on a laptop Mac OS X 10.11.
Steps to reproduce the bug:

1 Open Firefox
2 Enter to a page that have many information and pictures ex: 9gag.com
3 Scroll with a trackpad the web site.
4 While the scroll is still occurring, push cmd.
5 The page zooms instead of continuing to scroll.

Expected result: Page should not be zoomed

Actual results: Page is zoomed.
(In reply to ovidiu boca from comment #4)
> (In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #3)
> > (In reply to ovidiu boca from comment #2)
> > > 
> > > I can reproduce the bug on FF Nightly 44.0a1 (2015-10-26)
> > 
> > Do you have steps to reproduce? The steps in comment 0 are not sufficient to
> > reproduce this locally.
> 
> Hi Anthony, 
> 
> You need to reproduce this on a laptop Mac OS X 10.11.
> Steps to reproduce the bug:
> 
> 1 Open Firefox
> 2 Enter to a page that have many information and pictures ex: 9gag.com
> 3 Scroll with a trackpad the web site.
> 4 While the scroll is still occurring, push cmd.
> 5 The page zooms instead of continuing to scroll.
> 
> Expected result: Page should not be zoomed
> 
> Actual results: Page is zoomed.

These steps don't work for me on my Macbook Pro (Retina, Late-2013) running Mac OS 10.11.1 Beta. Do you have any other info that will help me reproduce this?

Comment 6

3 years ago
Hi Anthony,

If you can, please try to reproduce this steps on Chrome. And maybe this bugs: 1199737, 649770 can help you to reproduce the problem.

Updated

2 years ago
Flags: needinfo?(jmathies)

Updated

2 years ago
Flags: needinfo?(jmathies)
Whiteboard: [gfx-noted] → tpi:

Updated

2 years ago
Whiteboard: tpi: → tpi:+

Updated

2 years ago
Priority: -- → P2
Whiteboard: tpi:+ → [tpi:+][tpi-help-requested]

Comment 7

11 months ago
On FF 56.0 / Mac OS 10.13

I start a page scroll with the touchpad, then press the command key :

1. while fingers are still down on the touchpad and scrolling -> page zooms,
2. when fingers are lifted and scrolling occurs out of momentum -> page scroll continues.

As I understand, this bug states that page zooms in scenario 2.
Either I misunderstand the bug or I can't reproduce it.

Comment 8

10 months ago
Are you still able to reproduce this?
Flags: needinfo?(ovidiu.boca)

Comment 9

10 months ago
hi Stephen,
I retested this on MacBook OS X 10.11 with FF Nightly 58.0a1(2017-10-15) and I have the same results like André:

1. while fingers are still down on the touchpad and scrolling -> page zooms,
2. when fingers are lifted and scrolling occurs out of momentum -> page scroll continues.
Flags: needinfo?(ovidiu.boca)

Comment 10

10 months ago
I understand this is the expected behavior.
This bug has likely been fixed by a side effect of some other patch.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.