Lots of broken updates with error: "Error: Unexpected node name, expected: updates, got: parsererror"

RESOLVED DUPLICATE of bug 1216737

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 1216737
2 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(firefox44 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8678912 [details]
HTTP log

This can be seen by the results of the update tests as of today. Nearly all partial updates as generated by funsize for the en-US locale are broken. It might also apply for other locales but we don't test them.

mozilla-central:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=5ca03a00d268&filter-job_group_symbol=Fu&exclusion_profile=false

mozilla-aurora:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-aurora&filter-job_group_symbol=Fu&exclusion_profile=false

Here the excerpt from the log:

07:40:01 *** AUS:SVC Checker:getUpdateURL - update URL: https://aus5.mozilla.org/update/3/Firefox/44.0a1/20151025030428/Linux_x86-gcc3/en-US/nightly/Linux%203.13.0-53-generic%20(GTK%203.10.8)/default/default/update.xml?force=1
07:40:01 *** AUS:SVC Checker:checkForUpdates - sending request to: https://aus5.mozilla.org/update/3/Firefox/44.0a1/20151025030428/Linux_x86-gcc3/en-US/nightly/Linux%203.13.0-53-generic%20(GTK%203.10.8)/default/default/update.xml?force=1
07:40:02 *** AUS:SVC Checker:onLoad - request completed downloading document
07:40:02 *** AUS:SVC Checker:_updates get - unexpected node name!
07:40:02 *** AUS:SVC Checker:onLoad - there was a problem checking for updates. Exception: Error: Unexpected node name, expected: updates, got: parsererror
How is this bug different than bug 1216737?
This looks like it is the same issue as bug 1216737 so duping. If you can answer comment #1 as to why this is an app update bug and not a server side bug please reopen.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1216737

Comment 3

2 years ago
42 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-aurora: 39
* mozilla-central: 3

Platform breakdown:
* osx-10-9: 8
* osx-10-6: 8
* osx-10-10: 8
* osx-10-11: 5
* linux64: 5
* windows7-64: 3
* linux32: 3
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1218429&startday=2015-10-26&endday=2015-10-26&tree=all

Comment 4

2 years ago
42 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-aurora: 39
* mozilla-central: 3

Platform breakdown:
* osx-10-9: 8
* osx-10-6: 8
* osx-10-10: 8
* osx-10-11: 5
* linux64: 5
* windows7-64: 3
* linux32: 3
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1218429&startday=2015-10-26&endday=2015-11-01&tree=all
You need to log in before you can comment on or make changes to this bug.