Render glitch when scrolling a pane by dragging an object

VERIFIED DUPLICATE of bug 121187

Status

VERIFIED DUPLICATE of bug 121187
17 years ago
5 years ago

People

(Reporter: chris+bugzilla, Assigned: sspitzer)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.7+)
Gecko/20020125
BuildID:    2002012503


Scrolling the mail folder pane by dragging a mail message to the bottom of the
pane causes the window rendering to go haywire.  The same thing happens in
Manage Bookmarks when you try to drag a bookmark to the bottom of the list (when
you need to scroll down to find your destination) 

Reproducible: Always
Steps to Reproduce:
1. make sure your mail window is small enough that the left pane (folders) has a
scroll bar.
2. open a mail folder in IMAP mail
3. drag a message from that folder to the folder list
   continue dragging to the bottom of the list, so the pane scrolls

Actual Results:   
nasty, persistent rendering glitches cause the mail window to be redrawn basly
when the pane scrolls.  Cycling a redraw with maximize followed by unmaximize
fixes it.

Expected Results:   
folder pane scroll, so you can drop mail message into a folder.

Updated

17 years ago
QA Contact: esther → olgam

Comment 1

17 years ago
I see additional troubles with moving messages. Cursor keeps 'frame' for the
selected message when dragging a message. This 'frame' has size of the
selected/highlighted message depending on width of the Thread pane. 
Also try another scenario: make smaller and bigger the size of 3-pane and see
problems with repainting. I closed after this: Cmd+W, then Cmd+2 and still see
the problems: blank areas, partial Central page. Seth, if you think we need to
isolate it to another bug, comment it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
It seems that this is duplicate of bug 121187.
Recently I see other regressions with Mac OSX: like not having default focus,
not having Inbox as the first folder, getting Central page after password
entered - I log them separately. 
(Reporter)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 121187 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.