delivery: Directories without trailing slash return an error

RESOLVED WONTFIX

Status

Cloud Services
Operations
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: smontagu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
(I'm not 100% certain that this is a dependee of bug 1213721, but I'm fairly sure that it didn't happen before)

Any directory link without a trailing slash, from https://ftp.mozilla.org/pub/firefox/nightly or other sub-directories of firefox on down, returns an error "The specified key does not exist" (https://ftp.mozilla.org/pub/firefox and above add the trailing slash).
I have seen that too and we had to fix that in mozdownload to get it working again. Simply missed to file a bug for it. So good to see that this is tracked now.
This is an S3ism, maybe oremj has a cunning way of avoiding it.
Component: General Automation → Operations
Product: Release Engineering → Cloud Services
QA Contact: catlee
Summary: Directories without trailing slash return an error → delivery: Directories without trailing slash return an error

Comment 3

2 years ago
Nick is right. If there is no '/' we have no way of detecting whether or not the request is for a directory listing or file at the CDN layer. To implement this, we'd have to proxy all requests through something with knowledge of s3, which we want to avoid for performance, cost, and uptime reasons.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1223539
Created attachment 8685603 [details]
screenshot of the error page

Can we at least offer a more helpful error page, saying something like...
  File not found. Note: if you're looking for a directory, make
  sure you've got a trailing "/" at the end of your URL!

Right now the error page is just some XML gunk (see attached screenshot), which to me implies "Infra is broken, wait until it's fixed". It does not imply "check your URL and make sure you have a trailing slash".

(I've been hitting this error over & over for the past few weeks and had been assuming there was some pending FTP->S3 migration that just hadn't happened yet. Only realized that the problem was the missing "/" today.)
Flags: needinfo?(oremj)
Elaborating a bit -- note that this is an *extremely* easy bug to hit, given:
 (1) These directories lend themselves to being edited by hand.
 (2) This used to Just Work with FTP (so this is stuck in people's muscle memory)

So, in the absence of an actual fix, a more-helpful error message would be great for unblocking people when they (inevitably) hit this and wonder what all the XML gunk is about.

Comment 7

2 years ago
Thanks for the suggestion. I've added a custom 404 page.
Flags: needinfo?(oremj)
Thanks!
You need to log in before you can comment on or make changes to this bug.