Non-Nightly leaks of ImageContainerChild and TextureChild on Windows

RESOLVED DUPLICATE of bug 1232549

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1232549
3 years ago
2 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

(Whiteboard: [MemShrink:P2])

(Reporter)

Description

3 years ago
Similar to bug 1219369, when Nightly was merged over to Aurora some leaks showed up, with my new fine-grained leak detector for the content process:

TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many CondVar (expected 3, got 7)
TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many Mutex (expected 3, got 11)
TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many PImageContainerChild (expected 0, got 4)
TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many PTextureChild (expected 0, got 4)
TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many SharedMemory (expected 0, got 4)
TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many TextureChild (expected 0, got 4)
TEST-UNEXPECTED-FAIL | leakcheck | tab process: leaked too many WeakReference<MessageListener> (expected 2, got 10)

This is a new leak detector that I added recently, so it is possible we also were leaking these objects the last time Nightly was merged to Aurora, but we just didn't notice.

I think this leak is happening in a child process created while running dom/media/tests/mochitest/ipc/test_ipc.html

In the short term, I'll probably add a suppression so the tree is green, but it would be good if these leaks were fixed. Unlike bug 1219369, it seems like this may not be a singleton data structure leaking, but rather something that may leak more and more the longer we run, so it looks worse.
(Reporter)

Comment 1

3 years ago
This is showing up on Win7 and Win8 M2 debug, but not WinXP.
(Reporter)

Comment 2

3 years ago
Since we don't run any of the usual Windows e10s debug tests aside from this, this may just be a general problem with e10s on Windows, and not something specific to test_ipc.html.
(Reporter)

Comment 3

3 years ago
I filed bug 1219919 for the suppression.
Whiteboard: [MemShrink] → [MemShrink:P2]
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232549

Updated

2 years ago
See Also: → bug 1232549
You need to log in before you can comment on or make changes to this bug.