No option to change page's main directionality (LTR/RTL)

RESOLVED DUPLICATE of bug 85420

Status

()

RESOLVED DUPLICATE of bug 85420
17 years ago
10 years ago

People

(Reporter: ilya.konstantinov+future, Assigned: mkaply)

Tracking

({rtl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Internet Explorer has two additional items in the Encodings menu, allowing the
user to switch between "Right-to-left document" and "Left-to-right document".

This allows changing the main directionality of pages which fail to specify
their directionality and directionality of text/plain mails where it's
impossible to specify a BiDi directionality (except for UTF-8 mails).

The effect should be like setting a DIR=directionality attribute on the HTML
tree root.

Comment 1

17 years ago
dupe of bug 119857?
This is a dupe partly of bug 119857 but mostly of bug 85420, since the proposed
Bidi UI which has not yet been approved includes this function.

*** This bug has been marked as a duplicate of 85420 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.