Unable to print pages with long title (CUPS)

RESOLVED DUPLICATE of bug 1185236

Status

()

RESOLVED DUPLICATE of bug 1185236
3 years ago
3 years ago

People

(Reporter: RoMan.Shipovskij, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8681148 [details]
Title with more than 255 characters (256).html

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151023092914

Steps to reproduce:

Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.3 LTS
Release:	14.04
Codename:	trusty

Unable to print pages with title (or URI if no title) more than 255 characters (CUPS)

to reproduce just try to print attached html file


Actual results:

CUPS error: Print-Job client-error-attributes-or-values-not-supported

https://tools.ietf.org/html/rfc2911
4.1.2 'name'

   This syntax type is used for user-friendly strings, such as a Printer
   name, that, for humans, are more meaningful than identifiers. Names
   are never translated from one natural language to another. The
   'name' attribute syntax is essentially the same as 'text', including
   the REQUIRED support of UTF-8 except that the sequence of characters
   is limited so that its encoded form MUST NOT exceed 255 (MAX) octets.

   Also like 'text', 'name' is really an abbreviated notation for either
   'nameWithoutLanguage' or 'nameWithLanguage'. That is, all IPP
   objects and clients MUST support both the 'nameWithoutLanguage' and
   'nameWithLanguage' attribute syntaxes. However, in actual usage and


Expected results:

Page should be printed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Printing: Setup
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1185236
You need to log in before you can comment on or make changes to this bug.