Closed Bug 1220132 Opened 4 years ago Closed 4 years ago

disabled talos jobs should be run now that they are all green

Categories

(Testing :: Talos, defect)

defect
Not set

Tracking

(firefox45 fixed, b2g-v2.5 fixed)

RESOLVED FIXED
mozilla45
Tracking Status
firefox45 --- fixed
b2g-v2.5 --- fixed

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(4 files)

right now 3 jobs are disabled:
winxp: 'd'
osx: 'd'
winxp: 's-e10s'
the builder differences:
Builders added:
+ Rev5 MacOSX Yosemite 10.10 try talos dromaeojs-e10s
+ Rev5 MacOSX Yosemite 10.10 try talos g1-e10s
+ Rev5 MacOSX Yosemite 10.10.5 try talos dromaeojs-e10s
+ Rev5 MacOSX Yosemite 10.10.5 try talos g1-e10s
+ Windows 7 32-bit try talos xperf-e10s
+ Windows XP 32-bit try talos dromaeojs


Most likely these will have quick answers and we will quickly iterate on enabling by default or disabling again.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8681236 - Flags: review?(bugspam.Callek)
it appears that winxp-svgr-e10s is already enabled, the patch makes it much clearer.
Attachment #8681236 - Flags: review?(bugspam.Callek) → review+
in production
looking very green:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=12c4214c97ef

next step would be to enable these jobs in the same pattern the other platforms are.  We do have to watch out for beta/aurora.
Summary: disabled talos jobs should be able to run on try server so we can fix them up → disabled talos jobs should be run now that they are all green
here are the builders added:
+ Rev5 MacOSX Yosemite 10.10 fx-team talos dromaeojs-e10s
+ Rev5 MacOSX Yosemite 10.10 fx-team talos g1-e10s
+ Rev5 MacOSX Yosemite 10.10 mozilla-central talos dromaeojs-e10s
+ Rev5 MacOSX Yosemite 10.10 mozilla-central talos g1-e10s
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound talos dromaeojs-e10s
+ Rev5 MacOSX Yosemite 10.10 mozilla-inbound talos g1-e10s
+ Windows XP 32-bit alder talos dromaeojs
+ Windows XP 32-bit ash pgo talos dromaeojs
+ Windows XP 32-bit ash talos dromaeojs
+ Windows XP 32-bit cedar talos dromaeojs
+ Windows XP 32-bit fx-team pgo talos dromaeojs
+ Windows XP 32-bit fx-team talos dromaeojs
+ Windows XP 32-bit jamun talos dromaeojs
+ Windows XP 32-bit mozilla-aurora pgo talos dromaeojs
+ Windows XP 32-bit mozilla-aurora talos dromaeojs
+ Windows XP 32-bit mozilla-beta pgo talos dromaeojs
+ Windows XP 32-bit mozilla-beta talos dromaeojs
+ Windows XP 32-bit mozilla-central pgo talos dromaeojs
+ Windows XP 32-bit mozilla-central talos dromaeojs
+ Windows XP 32-bit mozilla-inbound pgo talos dromaeojs
+ Windows XP 32-bit mozilla-inbound talos dromaeojs


Only a few concerns:
* beta - older code, might not be applicable
* aurora - should have same code as uplift occurred last week, but different configs
* pgo* - didn't test pgo on try- for osx it doesn't matter, for windows it does.

Other than that, I know of no other caveats!
Attachment #8682610 - Flags: review?(bugspam.Callek)
Comment on attachment 8682610 [details] [diff] [review]
enable jobs by default now that they are all green

Review of attachment 8682610 [details] [diff] [review]:
-----------------------------------------------------------------

r+ if you verify greenness of *pgo and beta/aurora. and either fix or submit a new patch to re-disable those.
Attachment #8682610 - Flags: review?(bugspam.Callek) → review+
still waiting on aurora/beta data, but trunk looks great.  We still don't have xperf on e10s.  Let me verify aurora/beta before tackling that problem.
aurora is fine!  no new data on beta;  Also we will be disabling damp on winxp due to issues with getting a large page reloaded reliably.  This is a winxp only issue.
mozilla-beta is all good.

Now to figure out the xperf e10s
Comment on attachment 8684400 [details] [diff] [review]
simple talos.json fix to get xperf-e10s running (1.0)

Review of attachment 8684400 [details] [diff] [review]:
-----------------------------------------------------------------

Apparently xperf.config has migrating its way into some python file in which case this change sounds fine.
Attachment #8684400 - Flags: review?(wlachance) → review+
https://hg.mozilla.org/mozilla-central/rev/d7b34dc6ef9e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
after seeing this green on m-c, it is time to do this per change
Attachment #8684961 - Flags: review?(bugspam.Callek)
and the builders added:
Builders added:
+ Windows 7 32-bit fx-team pgo talos xperf-e10s
+ Windows 7 32-bit fx-team talos xperf-e10s
+ Windows 7 32-bit mozilla-inbound pgo talos xperf-e10s
+ Windows 7 32-bit mozilla-inbound talos xperf-e10s
Comment on attachment 8684961 [details] [diff] [review]
enable xperf-e10s on all integration branches (1.0)

Review of attachment 8684961 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/config.py
@@ -2330,4 @@
>  BRANCHES['try']['xperf-e10s_tests'] = (1, False, TALOS_TP_NEW_OPTS, WIN7_ONLY)
>  BRANCHES['try']['dromaeojs-e10s_tests'] = (1, False, {}, ALL_TALOS_PLATFORMS)
> -BRANCHES['try']['dromaeojs_tests'] = (1, False, {}, ALL_TALOS_PLATFORMS)
> -BRANCHES['try']['g1-e10s_tests'] = (1, False, {}, ALL_TALOS_PLATFORMS)

this hunk seems unrelated...
Attachment #8684961 - Flags: review?(bugspam.Callek) → review+
landed:
https://hg.mozilla.org/build/buildbot-configs/rev/3af2504ec4ae

thanks for pointing out the additional cleanup- it is intended and should make future editing simpler.

As far as I know, this is the last patch and when this is deployed we can close this bug for good!
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.