Awkward spacing on FTU About/Telemetry screen

VERIFIED FIXED in Firefox OS v2.5

Status

P3
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: sfoster, Assigned: sfoster)

Tracking

({polish})

unspecified
FxOS-S10 (30Oct)
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.5 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Created attachment 8681418 [details]
ftu-telemetry-logo-master.png

The logo is left-aligned and introductory paragraph seems cramped. Not sure if this was deliberate in an attempt to get everything above the fold, but as that will vary hugely in different languages I think we should just fix it and let it take the height it needs.
(Assignee)

Comment 1

3 years ago
Created attachment 8681420 [details]
ftu-telemetry-logo-patched.png

Proposed fix - centers the logo, adds 2rem padding between it and the intro paragraph.
Attachment #8681420 - Flags: ui-review?(epang)
Comment on attachment 8681420 [details]
ftu-telemetry-logo-patched.png

Looks good, thanks Sam!
Attachment #8681420 - Flags: ui-review?(epang) → ui-review+
Created attachment 8681489 [details] [review]
[gaia] sfoster:ftu-2-5-videos-bug-1212961 > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8681489 [details] [review]
[gaia] sfoster:ftu-2-5-videos-bug-1212961 > mozilla-b2g:master

Grr, got attached to wrong bug.
Attachment #8681489 - Attachment is obsolete: true
Created attachment 8681494 [details] [review]
[gaia] sfoster:ftu-telemetry-layout-bug-1220245 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → sfoster
Keywords: polish
Priority: -- → P3
Whiteboard: [systemsfe]
Target Milestone: --- → FxOS-S10 (30Oct)
(Assignee)

Comment 6

3 years ago
Comment on attachment 8681494 [details] [review]
[gaia] sfoster:ftu-telemetry-layout-bug-1220245 > mozilla-b2g:master

r=me for trivial, well-scoped FTU CSS change that has ui-review+
Attachment #8681494 - Flags: review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 7

3 years ago
Merged to master: https://github.com/mozilla-b2g/gaia/commit/b4f8752dea2d8d5d8cb8abbd7f3ab0b2c619a9c9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8681494 [details] [review]
[gaia] sfoster:ftu-telemetry-layout-bug-1220245 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): This screen was re-designed for 2.5
[User impact] if declined: Mis-aligned/cramped text on FTU telemetry screen
[Testing completed]: Verified on device
[Risk to taking this patch] (and alternatives if risky): V low risk, polish bug with FTU and screen-specific CSS changes
[String changes made]: none
Attachment #8681494 - Flags: approval-gaia-v2.5?

Comment 9

3 years ago
Created attachment 8682898 [details]
verified_Aries KK v2.6.png

According to the STR of Comment 0, this bug has been verified as pass on latest Flame KK v2.5 & v2.6, and Aries KK v2.6.

Actual results: The logo is left-aligned and introductory paragraph seems normally.
See attachment: verified_Aries KK v2.6.png
Reproduce rate: 0/6

Device: Flame KK v2.5 512mb (Pass)
Build ID               20151103004501
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4e0955369a51850f2982087145ac5c2df257ffe9
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151103.054921
Firmware Date          Tue Nov  3 05:49:36 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.6 512mb (master) (Pass)
Build ID               20151103150203
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151103.182550
Firmware Date          Tue Nov  3 18:26:03 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.6 (master) (Pass)
Build ID               20151104004249
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151104.000116
Firmware Date          Wed Nov  4 00:01:24 UTC 2015
Bootloader             s1

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.5: --- → verified
status-b2g-master: fixed → verified
Comment on attachment 8681494 [details] [review]
[gaia] sfoster:ftu-telemetry-layout-bug-1220245 > mozilla-b2g:master

This landed in 2.5. Updating approval flag

Thanks
Attachment #8681494 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.