save in Composer won't save first time

VERIFIED DUPLICATE of bug 109179

Status

--
critical
VERIFIED DUPLICATE of bug 109179
17 years ago
14 years ago

People

(Reporter: petes-lists, Assigned: Brade)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+) Gecko/20020126
2002012608

steps to reproduce:
- open Composer
- type something
- choose 'save'
message: "saving file failed!"
- choose 'save'
result: saves ok. and subsequent goes on the 'save' button work ok

but if you then:
- choose 'save as'
message: "saving file failed!"
- choose 'save'
result: saves ok. and subsequent goes on the 'save' button work ok

I am saving to a local partition. the browser can save without problems.

Comment 1

17 years ago
Confirmed on Win 2k and Xp using the 01-28 trunk build.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
What file are you editing? A local file? A remote (http) file? Please give an
example.
My tree is up to date as of 1/25 and doesn't show any problem.
Assignee: syd → brade

Comment 3

17 years ago
This problem seems to happen when either editing a webpage and then saving it 
locally, or when creating a new file and trying to save it.

Steps to Reproduce:
1. Launch browser and navigate to http://mozilla.org
2. Hold down CTRL - E to bring up page in Composer
3. Make a change to the page to bring up the Save icon on the toolbar
4. Click on Save icon on toolbar
5. Choose a filename and location, and click on Save
6. Receive message "Saving file failed!"

Or:
1. Launch Composer and open a new document
2. Make a change to the page to bring up the Save icon on the toolbar
3. Click on Save icon on toolbar
4. Choose a title, filename and location, and click on Save
5. Receive message "Saving file failed!"


Note:
I don't see this problem on the 01-25 build or any build earlier.

Comment 4

17 years ago
I agree -- exactly as Sujay has described, and it doesn't occur previous to 
today.
(Reporter)

Comment 5

17 years ago
Charles, I thought my original post was example enough, just open composer
(Tasks -> Composer), type something and save to a local partition.

I don't see this on a 0.9.8 branch build (2002012806)

Comment 6

17 years ago
BUILD 2002012903

Tested against two files.  Both files tested on Local and Network file system.

Save of changes via composer failed in all four cases.

Comment 7

17 years ago
I do not see this problem since the latest patch to bug 109179 was checked in.
The problem was that getting the URL string from nsIFile or nsILocalFile had the
format "file://..." rather than "file:///..."
This was breaking nsWebBrowserPersist::SaveDocumentInternal().
because we weren't constructing the proper aDataDir URI object.
Sujay has tested Mac and Linux platforms.

*** This bug has been marked as a duplicate of 109179 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
This problem appears to have been fixed by patch to bug 109179.
I am not seeing this problem anymore on the 01-30 trunk builds using Win ME, Win
Xp, Mac OS9 or Mac OSX.

Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.