MathML rendering on Wikipedia shows too much white space above/below text

RESOLVED DUPLICATE of bug 1208776

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 1208776
2 years ago
2 years ago

People

(Reporter: imphil, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(firefox41 unaffected, firefox42 unaffected, firefox43 affected, firefox44 affected, firefox45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8681693 [details]
Screenshot (comparing good/bad behavior)

[Please see the screenshot for the bug, it's much easier seen than described.]

STR
- Go to https://de.wikipedia.org/wiki/Beobachter_%28Regelungstechnik%29
- Log in and enable MathML rendering of the formulas
- See the math taking way too much space before and after the formula itself (see screenshot)

The web console says I'm using the font 
LatinModernMath-Regular system 
Used as: "Latin Modern Math"

I ran mozregression on this, and it came up with https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d977d6508ad3138c85a209c6ec61e50dfa51be12&tochange=7b56d6b86d1a92237c0a244054efcff86afb7fb3 as regression range. The most likely candidate is bug 1170782.

Please let me know if you need the font or any other system information.
(Reporter)

Updated

2 years ago
status-firefox41: --- → unaffected
status-firefox42: --- → unaffected
status-firefox43: --- → affected
status-firefox44: --- → affected
Depends on: 1170782
What is your system? Which version of Latin Modern Math do you use?
(Reporter)

Comment 2

2 years ago
I'm running OpenSUSE 13.2. The font seems to be the version from TeXLive 2013, which is still used in OpenSUSE 13.2 and (more importantly) Ubuntu 14.04 LTS (though I didn't check if the rendering looks the same in this Ubuntu version; I can check tomorrow if needed.)

$> fc-list -v 'LatinModernMath' fullname fontversion file
Pattern has 3 elts (size 16)
        fullname: "LatinModernMath-Regular"(s)
        file: "/usr/share/fonts/texlive-lm-math/latinmodern-math.otf"(s)
        fontversion: 128319(i)(s)


$> rpm -q -f /usr/share/fonts/texlive-lm-math/latinmodern-math.otf -i
Name        : texlive-lm-math-fonts
Version     : 2013.84.1.958svn29044
Release     : 16.1.7
Architecture: noarch
Install Date: Sa 03 Jan 2015 20:33:13 CET
Group       : Productivity/Publishing/TeX/Base
Size        : 733996
License     : LPPL-1.0
Signature   : RSA/SHA256, Mi 08 Okt 2014 19:25:01 CEST, Key ID b88b2fd43dbdc284
Source RPM  : texlive-lm-math-2013.84.1.958svn29044-16.1.7.src.rpm
Build Date  : Mi 08 Okt 2014 19:20:26 CEST
Build Host  : cloud129
Relocations : (not relocatable)
Packager    : http://bugs.opensuse.org
Vendor      : openSUSE
URL         : http://www.tug.org/texlive/
Summary     : Severed fonts for texlive-lm-math
Description :
The  separated fonts package for texlive-lm-math
Distribution: openSUSE 13.2
(In reply to Philipp Wagner [:imphil] from comment #2)
> I'm running OpenSUSE 13.2. The font seems to be the version from TeXLive
> 2013, which is still used in OpenSUSE 13.2 and (more importantly) Ubuntu
> 14.04 LTS (though I didn't check if the rendering looks the same in this
> Ubuntu version; I can check tomorrow if needed.)

Thanks, that seems to be a duplicate of bug 1208776. I invite you to install the latest version of Latin Modern Math from the upstream website. For OpenSUSE and Ubuntu, see:

https://bugs.launchpad.net/ubuntu/+source/lmodern/+bug/1502701
https://bugzilla.opensuse.org/show_bug.cgi?id=948624

The OpenSUSE maintainer does not seem to have time to upgrade TeXLive for now. I did not see much activity on Ubuntu side but Latin Modern is in a separate lmodern package and the bug is already fixed  in Debian testing so I expect that this will arrive soon in Ubuntu. I'm not sure what more can be done, but feel free to "help" the Linux distro maintainers :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1208776
You need to log in before you can comment on or make changes to this bug.