browser gets stuck when i press "send" in 3 major web mail services, with or withour attachments

RESOLVED DUPLICATE of bug 117363

Status

()

--
critical
RESOLVED DUPLICATE of bug 117363
17 years ago
17 years ago

People

(Reporter: urifrid, Assigned: rods)

Tracking

({hang})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

in www.linuxfreemail, mail.yahoo.com and www.ziplip.com when finishing writing
an email (text based, no html or formatted) i press send and the browser gets
stuck, mening it will show me the "connecting..." or any other message in the
status bar and it will never send the email or flag an error or show any
symptoms that it is alive.
i tried with and without attachements but the same happened in both cases.
Netscape on the same pages and with the same email shows no problems. this
happens in red hat Linux 7.2 and win 2k, using mozilla Mozilla 0.9.7
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221) for Linux and
similar version in win2k

Reproducible: Always
Steps to Reproduce:
1.log in as a user in yahoo mail (or linuxfreemail.com)
2.press compose, write message
3.press send

Actual Results:  browser gets stuck (endless loop?)

Expected Results:  n/a

*** This bug has been marked as a duplicate of 116210 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
just for the sake of argument i tried with both wrong file name and right file
names, plus without attachments. end result: exactly the same, it hangs
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
Reporter: Please use severity level "critical", and add the keyword "hang".
Thank you for using Bugzilla!
(Reporter)

Updated

17 years ago
Severity: normal → critical
Keywords: hang

Comment 4

17 years ago
Yahoo mail wfm, with, without attachments. Win2k 2002012808.
This is a duplicate.  The sites in question will add the attachments and then
leave the file upload field _blank_ which triggers bug 116210.

One can test on ziplip.com with username/password == mozilla/mozilla

*** This bug has been marked as a duplicate of 116210 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
what about the fact that in win2k you DON'T need to attach any file for this to 
happen, meaning that any thing you do, any mail you might want to send in 
yahoo, linuxfreemail or ziplip will get stuck, even without any attachments
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Let me reiterate. Any page which has a file upload control that is not filled in
will get stuck trying to upload using mozilla 0.9.7.  Please test these pages
with a current build in which bug 116210 is fixed.  If it still does not work in
that current build, _then_ reopen this bug.  I cannot reproduce the problem with
a current build.

*** This bug has been marked as a duplicate of 116210 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

17 years ago
ok, i might be a dumb person, but if after downloading the LATEST build the
problem is still there... i tried yesterday with latest build, it's the first
thing i tried after seeing that the bug was flagged as duplicated, and that's
why i reopened it yesterday.

sorry to bother, but never mind.
there was no need to be rude

it still doesn't work, i'm gonna try to fixe it myself, thanks
Status: RESOLVED → CLOSED
Um.. you never said it was also failing for you in a _recent_ build....  Sorry
for the misunderstanding.  Which exact recent build can you reproduce the
problem in?  Does the browser hang or does the form submission hang?  That is,
can you use the browser menus and the like?
Status: CLOSED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 10

17 years ago
it's ok, i've been going thru the source and i can't find anything, i mean i 
don't even know if i have the right sources.
build is: 2002012708 (downloaded from nightly builds in 1/27/2002)
i can use the menues and the buttons, when i press send the little animation on 
the right works but the status bar shows "done." and it;s like the browser is 
frozen, it goes like that as far as 21 minutes, (i set the time out to 30 
min.), i didn't try longer. the thing is that let's say in yahoo: when there 
are no attachments the field says "none" but it's NOT an edit box, it's just a 
label (if you run IE or Opera you'll see this) in Mozilla it says none but it's 
inside an edit box, yahoo won't let you write manually the file you HAVE to 
pick it from their page, in Mozilla it looks like if you CAN write the path 
yourself. that might be the problem.
->HTML Forms
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Form Controls
Ever confirmed: true
QA Contact: doronr → madhur
darin, how likely is this to be the content-length problem you found?

Comment 13

17 years ago
bz: it sounds like the very same problem.

*** This bug has been marked as a duplicate of 117363 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
The new code which fixed the content-length problem is now checked in.

urifrid@yahoo.com: If this works for you in a very recent nightly then please 
mark this bug as verified. If it still doesn't work then reopen this bug.
You need to log in before you can comment on or make changes to this bug.