Japanese text in device font in flash is displayed as garbage

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Koike Kazuhiko, Assigned: serge (gone))

Tracking

({intl})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA][THIS IS NOT A MOZILLA ISSUE -- FLASH ISSUE])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Japanese text in device font in flash is displayed as garbage
on Linux or FreeBSD.

http://www.cocacola.co.jp/index3.html
http://hfm-kenchan.com/

This isn't a bug of Mozilla, but should be resolved in some way.
Many sites use device fonts.


Original report in Bugzilla-jp:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=1783

Comment 1

16 years ago
Changed QA contact to ruixu@netscape.com.
QA Contact: shrir → ruixu

Updated

16 years ago
Keywords: intl
(Reporter)

Comment 2

16 years ago
*** Bug 135382 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
The plug-ins triage team (av, beppe, peterl, serge and shrir) have reviewed this
issue and have made the following determination:

This is not happening on winXP, so this may be linux only. Reassigning to Serge
for debugging on linux.

Shrir, will help verify this
Assignee: av → serge
Priority: -- → P3
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.1beta

Updated

16 years ago
Target Milestone: mozilla1.1beta → mozilla1.0.2

Updated

16 years ago
Target Milestone: mozilla1.0.2 → Future

Comment 4

16 years ago
rui xu, can you please check this ? Help is appreciated, Thanks! 
(Assignee)

Comment 5

16 years ago
Created attachment 94359 [details]
IE shows the same garbage

this is flash bug not mozilla, I doubt we can do anything with this.

Comment 6

16 years ago
adding Flash contact to cc list
Whiteboard: [PL2:NA] → [PL2:NA][THIS IS NOT A MOZILLA ISSUE -- FLASH ISSUE]

Comment 7

16 years ago
I checked this bug, it only can be reproduced on Linux, but it is not 
reproducible on JA Windows 98SE, JA and EN Win2K, SC WinXP, MacOS 9 and MacOS X.

Serge, I could not reproduce it with IE, I guess you do not have Japanese font 
support on your system, according to the attachment in comment #5.
(Reporter)

Comment 8

16 years ago
See this page. Flash player hardcoded font names.
http://www.macromedia.com/support/flash/ts/documents/flashfonts.htm
(Assignee)

Comment 9

16 years ago
yes, I do not have Japanese font support on w2k and on my linux boxes,
and on linux I got the same garbage as on w2k in IE.
my point is if any window system does not have an appropriate font to use,
you will get something unreadable. And this is not a mozilla problem, check out
ns4.x on linux, I'm positive you'll see the same.
I'm not a flash developer and nothing can say about flash and fonts, tough their
docs KOIKE Kazuhiko pointed out clear says:
"The main benefit to embedding font outlines is that text fields will always
display in the chosen font, regardless of whether that font is installed on the
playback system. Also, text fields whose fonts are embedded will always be
anti-aliased (smoothed) by the Flash Player."

Comment 10

16 years ago
So upon reading the referenced documentation (thank you kazhik@mozilla.gr.jp),
it states that the plug-in author can choose to use device fonts (fonts that
exist on the users system) or outline fonts. If the swf was created using the
device fonts option, then there will be instances where the text would not be
displayed correctly if the referenced font within the plug-in cannot be
successfully mapped to a system (device) font. It would be necessary for the
user to download the appropriate font. In addition, the author of the plug-in
should have provided some indication that the user may need to download a
particular font family.

Now that I have a clearer understanding of the issue - why is this bug still
open? This is an issue between the user and the fonts they have installed verses
the plug-in instance.

Comment 11

16 years ago
*** Bug 169230 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Hi,
My bug was the dup.

Which device fonts are necessary to get japanese to display? I have a
ja_JP.UTF-8 enviroment and it does not work, i have plenty of japanese fonts but
it seems these are not the correct "device fonts". How would i configure the
fonts for the flash plugin if its not mozilla thats the problem.

Why do macromedia release a flash plugin for linux that only works in english?
or is there a case where the flash plugin can be made to display japanese
correctly in X/linux ?

JG

Comment 13

16 years ago
This was resolved by Macromedia flash 6 r60 beta, those pages are displayed fine
with that version on linux RH7.2.

Updated

16 years ago
QA Contact: ruixu → ylong
(Assignee)

Comment 14

16 years ago
confirming flash 6 r60 beta rh7.3 fixes this problem.

Comment 15

16 years ago
http://www.cocacola.co.jp/index3.html does't use device fonts now.
http://hfm-kenchan.com/ uses not only device fonts but also embedded fonts.
I think that device font is displayed as garbage using 5.0 player,
and is not displayed at all using 6.0 player on Linux.

New testcase:

Static text in device font (Flash ver.4 swf)
http://www.t3.rim.or.jp/%7Eharunaga/test/devicefont_v4.html

Static text in device font (Flash ver.6 swf)
http://www.t3.rim.or.jp/%7Eharunaga/test/devicefont.html

Dynamic text in device font (Flash ver.4 swf, Shift_JIS text file)
http://www.t3.rim.or.jp/%7Eharunaga/test/dynamictext_v4.html

Dynamic text in device font (Flash ver.6 swf, UTF-8 text file)
http://www.t3.rim.or.jp/%7Eharunaga/test/dynamictext.html

Can you see Japanese text on Linux?

BTW, this is Flash's bug, not Mozilla's, I think too.
Product should be changed to Tech Evangelism.

Comment 16

16 years ago
Yes, those 4 test cases are displayed fine with me on linux RH7.2-JA / flash 6
r60 beta (this is macromedia's new release).

Comment 17

16 years ago
I observed the same problem on my config, but managed to fix them.

- Mozilla 1.0 Gecko/20020623 on Debian mixed.
 -> With flashplugin 5.0, garbage on test (see comment #15) sites.
 -> Upon flashplugin 6,0,60,67 installation, no text is displayed at all on the
test sites.

- Fixing Steps :

After seeing original report http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=1783,
and another ressource ( http://pc.2ch.net/test/read.cgi/linux/1036172033/l50 );

+ install others japanese fonts :
kochi-gothic.ttf and kochi-mincho.ttf ( deb packages : ttf-kochi-gothic /
ttf-kochi-mincho ).

=> test sites are now displaying correct text... But not sony.co.jp (garbage
still displayed)

+ lanching mozilla using : Export LANG=ja_JP ; mozilla

=> www.sony.co.jp's flash now works, displaying correct japanese text.

Basicly, all the steps are described on the original bugzilla(..)gr.jp report.
(selecting text is still not working properly...)

Comment 18

16 years ago
The beta version of Flash 6
(http://www.macromedia.com/software/flashplayer/special/beta/) should resolve
this problem

Comment 19

15 years ago
It is fixed on flash6 released version.
configuration tips is same as beta.

--
Additional info for configuration tips

1. font configuration

If /etc/X11/fs/config exists, add /usr/share/fonts/flash6 to 
categories.
If not exist, add 'FontPath "/usr/share/fonts/flash6"' to /ets/X11/XF86Config*

2. copy or make symlink for these fonts.

/usr/share/fonts/flash6/kochi-gothic.ttf
/usr/share/fonts/flash6/kochi-mincho.ttf

3. make fonts.dir file

# cd /usr/share/fonts/flash6/
# ttmkfdir , > fonts.scale
# cp fonts.scale fonts.dir

NOTE: This step is automatically done on RHL (/etc/init.d/xfs restart)

4. restart mozilla.

Comment 20

15 years ago
should this be marked FIXED as per comment 19 ?

Comment 21

11 years ago
WFM per comment 19
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.