Open Bug 1220666 Opened 4 years ago Updated 5 months ago

Accelerometer not working on Nexus 5/Android 6.0

Categories

(Firefox for Android :: General, defect, P3)

ARM
Android
defect

Tracking

()

Tracking Status
firefox44 --- affected
firefox45 --- affected
fennec - ---
firefox67 --- affected
firefox68 --- affected

People

(Reporter: ioana.chiorean, Unassigned)

Details

Attachments

(1 file)

Steps:
1. Go to http://people.mozilla.com/~nhirata/html_tp/accel_bug615597.html

Expected Results: 
- The page is loaded displaying a black rectangle with a black dot in it that moves with the device motion

Actual Results: 
- The black dot doesn't moves with the device motion

Notes:
- the page loads a static thing - see attached photo. 
Nothing much in the logs but here they are: https://pastebin.mozilla.org/8851102
tracking-fennec: --- → ?
Confirmed on Nexus 5. Cannot reproduce using a Nexus 5x running Android 6 or Galaxy S 5 running Android 5. This seems to be device specific not directly related to Android 6.0.
No longer blocks: android-m
Finkle reports that it is busted in release too. Not worth tracking.
tracking-fennec: ? → -

I encountered something similar to this issue on device Lenovo TB3-850M (Android 6.0.0) and build Firefox Beta 68.0b7, Firefox Nightly 68.0a1(2019-06-03), Firefox Release 67.0 with link: https://goo.gl/wNbfio, the page is loaded, the html5 icon is displayed but no device motion present.

Note: The site identifies that device orientation is supported by the device.

Triaging as P3 for now. Doesn't seem to be a widespread issue.

Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.