Unable to play 3gp music file

RESOLVED DUPLICATE of bug 1217220

Status

()

RESOLVED DUPLICATE of bug 1217220
3 years ago
3 years ago

People

(Reporter: MaxIvanov, Unassigned)

Tracking

({regression, verifyme})

unspecified
ARM
Gonk (Firefox OS)
regression, verifyme
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.6?, b2g-v2.2 unaffected, b2g-v2.5 unaffected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:
Unable to play 3gp music file

Repro Steps:
1) Update a Flame to 20151102030250
2) Copy 3gp music file to your phone http://lxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/resources/MUS_0001.3gp
3) Open the music app
4) Play your 3gp music file

Actual:
3gp music file is not playing

Expected:
File should plays without any issues

Environmental Variables:
Device: Flame Master
Build ID: 20151102030250
Gaia: bfcf8e9bfa7ba264c5f8bc865ce8a435f9b134cb
Gecko: 451a185791433bce1a6a894c27f3da60a3119431
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: (100%)
See attached: (video clip, logcat)
https://youtu.be/Jhr1UHOEgss
(Reporter)

Comment 1

3 years ago
I cannot verify this issue on Aries device because there is still no a new build, but is works fine on Friday's build. 

This does not occur on Flame Master (KK)(512mb) Friday's build
3gp music file plays as expected

Build ID: 20151030120435
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: c2534acb485963331d67bbc5c07f0d862ed56bf5
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
------------------------------------------------------------------------

This does not occur on the Flame 2.2
3gp music file plays as expected

Device: Flame 2.2 (KK)(319mb)
Build ID: 20151102032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: b8b7f4efaa6e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing]
(Reporter)

Comment 2

3 years ago
Created attachment 8682078 [details]
logs.txt
blocking-b2g: --- → 2.6?
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Whiteboard: [2.5-Daily-Testing] → [2.6-Daily-Testing]
status-b2g-v2.5: --- → unaffected
QA Whiteboard: [QAnalyst-Triage?]
QA Contact: pcheng

Comment 3

3 years ago
There have been no changes to the Music app since Friday, so it's not something in this component. My guess is something in the Gecko/Gonk layer; maybe we're not talking to libstagefright correctly anymore?
Component: Gaia::Music → Audio/Video: Playback
Product: Firefox OS → Core
mozilla inbound regression window:

Last Working
Device: Flame
BuildID: 20151029163913
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: d3a2e391df48f1c9389bdc132eb72065442dc2db
Version: 45.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

First Broken
Device: Flame
BuildID: 20151029165112
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: 9a44575026505c955bdda462d6ad346d197ab107
Version: 45.0a1 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d3a2e391df48f1c9389bdc132eb72065442dc2db&tochange=9a44575026505c955bdda462d6ad346d197ab107

I have triple checked that this window is the right window (that the last working does not reproduce the bug, and that the first broken reproduces the bug). However there are not relevant pushes in the pushlog.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Joel and Jim, I don't see how the backout of the issue in the pushlog from comment 4 caused this issue, but is it possible?  If not we will try again, but this window was checked to be accurate multiple times.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(squibblyflabbetydoo)
Flags: needinfo?(jmercado)
Flags: needinfo?(jmaher)
I backed out jemalloc4 which is only available on nightly/trunk.  It is unstable code, but when it is stable enough it should ride the trains.  As for jemalloc4 being the root cause here, I don't know much about it.  I had backed it out for performance reasons and will be turning it on in the near future when we sort out a memory regression.  For reference we did this 6 weeks ago on the last uplift, I assume you would have seen this happen between September 18 and 23?  

That might help figure this out.  You could also push to try with the patch landed again!
Flags: needinfo?(jmaher)

Updated

3 years ago
Flags: needinfo?(squibblyflabbetydoo)
Looks like the same problem as bug 1217220. (2 output buffers for one input sample in this case.)
Set this as a dup.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1217220
Resolution: --- → DUPLICATE
Duplicate of bug: 1217220

Comment 8

3 years ago
add verifyme in advance and need to verify this issue once bug1217220 is fixed
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.