Some failures still cannot be starred

RESOLVED DUPLICATE of bug 1220445

Status

Tree Management
Treeherder: API
RESOLVED DUPLICATE of bug 1220445
2 years ago
2 years ago

People

(Reporter: nigelb, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
I logged the HTTP 503 response and this is what I saw

"detail": "(1062, "Duplicate entry '16721616-1213631' for key 'uni_job_id_bug_id'")"

Job in question:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=dcc0164e001ac65a132a093a8f8edfc5641d3103&revision=7b99659430b1

Comment 1

2 years ago
The job in question:
https://treeherder.mozilla.org/api/project/mozilla-inbound/jobs/16721616/

->     "failure_classification_id": 4,

https://treeherder.mozilla.org/api/project/mozilla-inbound/bug-job-map/?job_id=16721616

    {
        "bug_id": 1213631,
        "submit_timestamp": 1446532168,
        "who": "autoclassifier",
        "type": "autoclassification",
        "job_id": 16721616
    }

https://treeherder.mozilla.org/api/project/mozilla-inbound/note/?job_id=16721616

    {
        "note_timestamp": 1446532168,
        "job_id": 16721616,
        "who": "autoclassifier",
        "failure_classification_id": 7,
        "note": "",
        "active_status": "active",
        "id": 308877
    }
It seems like the problem here happens when someone tries to star a job with the same bug id that the autoclassifier already added. There are a couple of mysteries, however:

1) Why is the autoclassifier running at all?
2) Why can't you see the associations above in the UI

In any case the endpoint should do get_or_create() or something so that readding the same bug that's already been added is a noop.

Comment 3

2 years ago
My bad, looks like I didn't update the stage/production branches correctly, they didn't have the revert on them, so in fact whilst we did a deploy, it was a no-op. Was mid work-week and so didn't check as thoroughly the revision present on those branches (my git checkout must have not been on master when I did the stage branch creation).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1220445
You need to log in before you can comment on or make changes to this bug.