Following error in console to auto-prettified minified source provides the wrong line.

RESOLVED DUPLICATE of bug 670002

Status

RESOLVED DUPLICATE of bug 670002
3 years ago
4 months ago

People

(Reporter: alekulyn, Unassigned)

Tracking

43 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151029004130

Steps to reproduce:

Load a minified JavaScript source with an error in it.  Make sure to have auto-prettify in the debugger enabled.
Try to trigger the error on the page or in the console.  In the console, click the hyperlinked source file and line to go to the debugger.  The debugger shows the line of the error in the minified source, not the auto-prettified source.


Actual results:

The debugger shows the line of the error in the minified source, not the line in the auto-prettified source.


Expected results:

I expected it to show the correct line in the auto-prettified source.
Component: Untriaged → Developer Tools: Debugger
Thanks for the report. The pretty printing uses source maps under the covers and the console doesn't support them yet. This will be fixed when that is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 670002

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.