Tree items get expanded when switching between snapshots

RESOLVED FIXED in Firefox 45

Status

()

Firefox
Developer Tools: Memory
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mboldan, Assigned: fitzgen)

Tracking

(Blocks: 1 bug)

44 Branch
Firefox 45
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Reproducible with Nightly 44.0a2 (2015-11-03)
Affected platforms: Windows 10 x32, Ubuntu 13.10 x64 and Mac OS X 10.11

Steps to reproduce:
1. Launch Firefox and enable the `devtools.memory.enabled` pref.
2. Enable the Toggle tools from the Developer option.
3. Select the Memory tool and take 2 snapshots.
4. Switch between snapshots.

Expected results:
The snapshots are correctly displayed.

Actual results:
The 'Name' column is detailed if switching between snapshots.
(Reporter)

Comment 1

3 years ago
I am attaching a video for the logged issue - https://bugzilla.mozilla.org/attachment.cgi?id=8682365 .
Blocks: 1221506
Mihai, by "detailed" do you mean that it gets expanded?
Has STR: --- → yes
See Also: → bug 1219076
(Reporter)

Comment 3

3 years ago
Yes, that's what I meant.
Is suspect this is the same underlying issue as bug 1219076, but since they are somewhat different STR, we should fix one and then not close the other bug until we've verified that it is also fixed.
Summary: The 'Name' column from the memory tool is detailed if switching between snapshots → Tree items get expanded when switching between snapshots
Created attachment 8683402 [details] [diff] [review]
Disable automatic expanding of memory tool's tree items
Attachment #8683402 - Flags: review?(jsantell)
Assignee: nobody → nfitzgerald
Status: NEW → ASSIGNED
Duplicate of this bug: 1219076
Attachment #8683402 - Flags: review?(jsantell) → review+

Comment 9

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/67c49cc5adc9
https://hg.mozilla.org/mozilla-central/rev/c54d609af6d5
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
You need to log in before you can comment on or make changes to this bug.