checksums failing for 43.0b1

RESOLVED FIXED

Status

Release Engineering
Release Automation
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed, firefox44 fixed, firefox45 fixed, b2g-v2.5 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
17:32:47     INFO - #####
17:32:47     INFO - ##### Running upload step.
17:32:47     INFO - #####
17:32:47     INFO - Running main action method: upload
One (and only one of UPLOAD_PATH or UPLOAD_TO_TEMP must be defined.

The problem is that we're passing path="dummy" and upload_to_temp_dir=True to http://hg.mozilla.org/releases/mozilla-beta/file/6e78daec52af/build/upload.py#l190
at http://hg.mozilla.org/releases/mozilla-beta/file/6e78daec52af/testing/mozharness/scripts/release/generate-checksums.py#l243
(Assignee)

Comment 1

2 years ago
Created attachment 8682885 [details] [diff] [review]
[gecko] Stop passing "dummy"
Attachment #8682885 - Flags: review?(jlund)
(Assignee)

Comment 2

2 years ago
The error above was for Fennec, but we'll hit it for Firefox too so lets land on both relbranches and retag. It'll need to go on m-c and m-a eventually to.

Comment 3

2 years ago
Comment on attachment 8682885 [details] [diff] [review]
[gecko] Stop passing "dummy"

Review of attachment 8682885 [details] [diff] [review]:
-----------------------------------------------------------------

:( more uplift fun.

I think None might not be an acceptable value as we will still treat it like a string: https://hg.mozilla.org/mozilla-central/rev/b41a88070b1b#l1.81

iiuc, we have to either tweak UploadFiles() a lot more or we pass an empty string.

Comment 4

2 years ago
Comment on attachment 8682885 [details] [diff] [review]
[gecko] Stop passing "dummy"

Review of attachment 8682885 [details] [diff] [review]:
-----------------------------------------------------------------

oh sorry, I guess we could do this because we set path to upload_to_temp_dir just before that: https://dxr.mozilla.org/mozilla-central/source/build/upload.py#209
Attachment #8682885 - Flags: review?(jlund) → review+
(Assignee)

Comment 6

2 years ago
Fixed in 43.0 and later, 42 is unaffected.

Comment 7

2 years ago
will let the m-c land close this bug out
status-firefox43: --- → fixed
status-firefox44: --- → fixed

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/717b8114f16a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED

Comment 9

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/3b6702f55a19
status-b2g-v2.5: --- → fixed
You need to log in before you can comment on or make changes to this bug.