Back button is enabled on FirstRun page

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1889234] [fxa], URL)

(Reporter)

Description

2 years ago
Reproducible with Firefox 43.0b1 build 2 (Build ID: 20151103023037) and 42.0RC build 2 (Build ID: 20151029151421)
Affected platforms: Mac OS X 10.10.4, Windows 7 64-bit and Ubuntu 14.04 32-bit

Steps to reproduce:
1. Launch Firefox with a clean profile.

Expected result:
Back button disabled.

Actual result:
Back button is enabled on FirstRun page. Clicking on it reloads the page and 'Forward' button is visible for a second.

Additional notes:
1. Not reproducible with latest 44.0a2 and 43.0a2 (from 2015-10-14), nor with latest Nightly 45.0a1.
2. Also reproducible with 42 beta, but not with 39 beta - will investigate further for the regression range.
3. As a side issue, when I navigate to any other URL from FirstRun page and Hit back button, the 'Go Forward' button vanishes. Should I file a separate issue or it's ok to be tracked here?
4. This issue and the above one (Additional notes 3) are not reproducible on https://www.mozilla.org/en-US/firefox/42.0/firstrun/learnmore/
I think this is likely a Firefox issue rather than a website issue, so moving to Firefox Tours component.
Component: Pages & Content → Tours
Product: www.mozilla.org → Firefox
Version: Production → 42 Branch
I think it's a website issue.
https://www.mozilla.org/en-US/firefox/39.0/firstrun/ doesn't reproduce the problem if opened in a blank tab.
https://www.mozilla.org/en-US/firefox/40.0/firstrun/ reproduces the problem.
It doesn't depend on the FF version.
Interesting - you are correct. It looks like an issue triggered by the Firefox Accounts iframe
Component: Tours → Pages & Content
Product: Firefox → www.mozilla.org
Version: 42 Branch → Production
Whiteboard: [kb=1889234]
I'm not sure if there's anything we can do on the mozorg side to fix this bug, it seems to be something in the iframe code that causes the history to change?
(In reply to Alex Gibson [:agibson] from comment #4)
> I'm not sure if there's anything we can do on the mozorg side to fix this
> bug, it seems to be something in the iframe code that causes the history to
> change?

Yes, the firstrun flow loads FxA to root - `/`. When `/` is opened, we look at whether the user is currently signed in. If the user does not have an FxA session, we redirect them to `/signup`, if they are, we send them to `/settings`. Both of these use `history.pushState`, taken care of by Backbone's router.

Perhaps a `history.replaceState` would be better for this situation.
Whiteboard: [kb=1889234] → [kb=1889234] [fxa]
Opened https://github.com/mozilla/fxa-content-server/issues/3296 to track from the content server side.
(In reply to Shane Tomlinson [:stomlinson] from comment #6)
> Opened https://github.com/mozilla/fxa-content-server/issues/3296 to track
> from the content server side.

Thanks, Shane!

Updated

2 years ago
A fix for this is waiting for review at https://github.com/mozilla/fxa-content-server/pull/3395
I cannot reproduce the issue anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.