Need an API for embedding Editor into a webpage

VERIFIED DUPLICATE of bug 97284

Status

()

VERIFIED DUPLICATE of bug 97284
17 years ago
17 years ago

People

(Reporter: kaldari, Assigned: kinmoz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla really needs an API for embedding and manipulating an HTML/text 
editor in a webpage. Perhaps something similar to Micro$ofts's MSHTML 
API.

<evangelist spam>
This is critical if you want web application developers to develop their 
apps with Mozilla-compatibility. Just get on the mozilla DOM newsgroup 
sometime and count how many web app developers are complaining 
about this "missing feature". As much as I hate to admit it, Microsoft is way 
ahead of Mozilla in the dynamic content arena. I realize Mozilla has better 
support for Range objects and DOM2 stuff, but Microsoft's APIs are much 
easier to use (and in many cases, more powerful). If Mozilla could 
implement an easy way of embedding Editor into a webpage, it would 
definitely help to close the gap with Explorer. Otherwise the next 
generation of the web really will be "IE-only".
</evangelist spam>
(Reporter)

Updated

17 years ago
Depends on: 35639

Updated

17 years ago
QA Contact: mdunn → depstein

Comment 1

17 years ago
-> Editor

Probably a dupe since this has been wanted in embedding for some time.
Assignee: adamlock → kin
Component: Embedding: APIs → Editor: Core
QA Contact: depstein → sujay

Comment 2

17 years ago
This is basically a dup of 97284 "[RFE] allow arbitrary elements to become
editable by user in browser"

*** This bug has been marked as a duplicate of 97284 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.