Green screen when seeking out of a keyframe on a video played with MediaSource extension

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: inscription, Assigned: jya)

Tracking

(Blocks 1 bug)

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36
Build ID: 20151028004029

Steps to reproduce:

Go on this page http://streamroot.test.s3.amazonaws.com/test-client/testErica.html
seek to 77 seconds (`$('video').currentTime = 77`)


Actual results:

The screen goes full green, and then the video starts playing for a few seconds on this green background until the next keyframe is reached.


Expected results:

Same result as when seeking on a keyframe (for instance at 75.5s `$('video').currentTime = 75.5`)
(Reporter)

Updated

4 years ago
Blocks: MSE
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
(Assignee)

Updated

4 years ago
Assignee: nobody → jyavenard
(Assignee)

Comment 1

4 years ago
You can only get this behaviour if keyframes are incorrectly marked as keyframe.

The first time I ran the demo, I could see that the media segment were 4s long, and the first frame of each media segment was marked as a keyframe. Seeking then didn't show a problem.

However, when seeking to 5 minute 40, I got a stream where all video frames in the media segments were marked as key frame.
Upon refreshing the page, I now mostly get those incorrectly muxed stream.

The behaviour you describe is observed with all browsers I've tried (couldn't test with safari due to XMLHttpRequest cannot load http://wowza-prod.cloudapp.net:1935/vod/mp4:sample.mp4/manifest.mpd. Cannot use wildcard in Access-Control-Allow-Origin when credentials flag is true.), indicating to me that the content is badly mixed and keyframes are improperly tagged as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.