Reloading a page uses direct connection if proxy is offline

RESOLVED DUPLICATE of bug 1207798

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1207798
2 years ago
2 years ago

People

(Reporter: aparan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151103030248

Steps to reproduce:

1. Use a SOCKS proxy in the proxy settings with remote DNS (Manual proxy configuration)
2. Stop the proxy after loading some page.
3. Open another URL.
4. The proxy server is refusing connections message is shown.
5. Reload the URL again.


Actual results:

Browser connects to the URL directly.


Expected results:

As proxy config is manual, it should not use direct connection. This has privacy concerns.

Comment 1

2 years ago
seems dup of Bug 1207798
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207798

Updated

2 years ago
Component: Untriaged → Networking
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.