Closed Bug 122210 Opened 18 years ago Closed 18 years ago

Newlines of title attributes should not be displayed in tooltips

Categories

(Core :: Layout, defect)

x86
Windows NT
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 67127

People

(Reporter: Klaus.Malorny, Assigned: attinasi)

Details

In Html, attributes may contain newline characters, i.e., may go over more than
one line:

<html>
<body>

<span title="This text contains a newline
here">move mouse over here</span>

</body>
</html>



If the content of the title attribute is displayed in a tooltip, it is displayed
as is, i.e. the newline character is drawn (as a small black box, as there is no
corresponding character in the font). IMHO, the content of the title attribute
should be displayed normalized by replacing any sequence of white space
(including newline) with a single space character. If a newline appears
explicitly (#&10;), it would be nice if the tooltip would contain multiple
lines, but this is an RFE and beyond the scope of this bug.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.