[Browser] After you generate a PIN to the homescreen, if you long press the PIN to enter edit mode, the edit icon is not available.

RESOLVED DUPLICATE of bug 1231846

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 1231846
2 years ago
2 years ago

People

(Reporter: Sharon, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 disabled, b2g-v2.5 affected, b2g-master affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8684140 [details]
Aries_v2.6.3gp

[1.Description]:
[Aries KK_v2.6][Flame KK_v2.6&v2.5&2.2][Flame_v2.5&2.2][Browser]Pin to any url to the homescreen,  long press the PIN in homescreen,  the edit icon is not available.
See attachment: logcat_2200.txt & Aries_v2.6.png & Aries_v2.6.3gp
Found time:22:00

[2.Testing Steps]: 
1.Open Brower app;
2.Enter any web page in address bar;(eg:www.baidu.com)
3.Tap the menu icon->Pin->Pin page;
4.Tap Home key,Sliding interface to the right;
5.Long press the PIN, to observe the interface display.

[3.Expected Result]: 
5.Edit button is available, and PIN can be edited.

[4.Actual Result]: 
5.Edit button is displayed as gray, and user is unable to edit the PIN.

[5.Reproduction build]: 
Device: Aries KK 2.6 (Master)(Affected)
Build ID               20151105235624

Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919

Gaia Date              2015-11-05 18:52:32

Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d

Gecko Version          45.0a1

Device Name            aries

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.worker.20151105.231433

Firmware Date          Thu Nov  5 23:14:41 UTC 2015

Bootloader             s1

Device: Flame KK v2.6 512mb (Master)(Affected)
Build ID               20151105150203
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.182857
Firmware Date          Thu Nov  5 18:29:10 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 512mb (Affected)
Build ID               20151105004500
Gaia Revision          47da49f8206788d70d834c3a63d9245d50c89103
Gaia Date              2015-11-03 21:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/5c9fd135d4309239794126f1942d6e7aa8b3579c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.043012
Firmware Date          Thu Nov  5 04:30:24 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.TCID]:
V2.2 version does not support the PIN function.
(Reporter)

Comment 1

2 years ago
Created attachment 8684145 [details]
Aries_v2.6.png
(Reporter)

Comment 2

2 years ago
Created attachment 8684148 [details]
logcat_2200.txt
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → disabled
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected

Comment 3

2 years ago
This is an expected behavior. Please refer bug 1231846 comment 5.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231846
You need to log in before you can comment on or make changes to this bug.