Notification with icon isn't shown

RESOLVED WORKSFORME

Status

()

Core
DOM: Push Notifications
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
To reproduce:
- Clone https://github.com/marco-c/serviceworker-cookbook/tree/rich_push_notification
- Run 'npm install'
- Run 'gulp start-server'
- Open 'http://localhost:3003/push-rich/index.html'
- Click on the button

The result is that no notification is shown.

This is the service worker code:
self.addEventListener('push', function(event) {
  event.waitUntil(self.registration.showNotification('ServiceWorker Cookbook', {
    lang: 'la',
    body: 'Alea iacta est',
    icon: 'caesar.jpg',
    vibrate: [500, 100, 500],
  }));
});

If I comment out the line that defines the icon property, the notification is shown.
Working on Firefox Nightly on OSX
(Reporter)

Comment 2

3 years ago
So it's a Linux specific issue.
OS: Unspecified → Linux
(Reporter)

Updated

3 years ago
Blocks: 1201571
(Reporter)

Comment 3

3 years ago
It works now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
This was probably a dupe of bug 1178061 but I'm guessing you're using Ubuntu where we now use XUL due to Ubuntu restrictions.
(Reporter)

Comment 5

3 years ago
Yes, I forgot I changed my machine and OS in the meantime :)

I've just tried on Fedora though, which is using libnotify, and it's working (intermittently?).
(Reporter)

Comment 6

3 years ago
Created attachment 8695815 [details]
screen.png
You need to log in before you can comment on or make changes to this bug.