Closed Bug 1222564 Opened 4 years ago Closed 4 years ago

Volume level does not persist after reboot

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5?, firefox45 fixed, b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master verified)

RESOLVED FIXED
FxOS-S11 (13Nov)
blocking-b2g 2.5?
Tracking Status
firefox45 --- fixed
b2g-v2.2 --- unaffected
b2g-v2.5 --- affected
b2g-master --- verified

People

(Reporter: MaxIvanov, Assigned: sotaro)

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(3 files)

Description:
Volume level doesn't persist after rebooting a phone and resets to the default value

Repro Steps:
1) Update a Aries to 20151106140230
2) Change your volume level using the volume buttons
3) Restart your phone
4) Verify your volume level

Actual:
After rebooting the volume level is about 50 % which is default value

Expected:
After rebooting the volume level should be the same as before reboot

Environmental Variables:
Device: Aries Master
Build ID: 20151106140230
Gaia: cec4c1d3729137a24163756d15f98b0d37803966
Gecko: 512caeeb5565bb819a24ebda6a37b44fdf71b6c3
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: (100 %)
See attached: (logcat)
This does occur on Flame master and Flame 2.5
After rebooting the volume level resets to the default value

Device: Flame Master (KK)(512mb) 
Build ID: 20151106030214
Gaia: f39a7a827c0c0f48087ff3ead94f61ae22523919
Gecko: cc48981c026c50fdf80d47b040ae1fb8fe99ad07
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
--------------------------------------------------------------------------

Device: Flame Master (KK)(512mb) 
Build ID: 20151029045227
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: acb3f4ac5424181d3d4d73283668162137918cf1
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

This does not occur on Flame 2.2 
After rebooting the volume level remains the same as before reboot

Device: Flame 2.2 (KK)(319mb) 
Build ID: 20151105032504
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 9d91dfad5e16
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.6-Daily-Testing][Spark]
Attached file logs_before_reboot.txt
[Blocking Requested - why for this release]:

This could lead to end user frustration since their set volume levels are reset after restart. Nominating 2.5?
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: mmurrell
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK master
Build ID               20151028070735
Gaia Revision          2e89362de40a6c9c36525d36317fa1ae8e67e143
Gaia Date              2015-10-28 04:56:28
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/f23234d57557fabc79e1635472de6ae8040fe4d8
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151026.070911
Firmware Date          Mon Oct 26 07:09:23 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK master
Build ID               20151028071133
Gaia Revision          2e89362de40a6c9c36525d36317fa1ae8e67e143
Gaia Date              2015-10-28 04:56:28
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/29c9e01ef7a297e35d42ea127e76f6b79377af59
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151026.070911
Firmware Date          Mon Oct 26 07:09:23 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro
Gaia Revision          2e89362de40a6c9c36525d36317fa1ae8e67e143
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/f23234d57557fabc79e1635472de6ae8040fe4d8

First Broken Gecko & Last Working Gaia – issue DOES repro
Gaia Revision          2e89362de40a6c9c36525d36317fa1ae8e67e143
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/29c9e01ef7a297e35d42ea127e76f6b79377af59

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f23234d57557fabc79e1635472de6ae8040fe4d8&tochange=29c9e01ef7a297e35d42ea127e76f6b79377af59


Hi Sotaro,

    This bug is probably caused by Bug 1196724, could you help to check?  

Thank you.
Flags: needinfo?(sotaro.ikeda.g)
QA Whiteboard: [MGSEI-Triage+]
I take a look.
Component: General → AudioChannel
Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → sotaro.ikeda.g
Attachment #8685290 - Flags: review?(alwu)
Comment on attachment 8685290 [details] [diff] [review]
patch - Save audio volume to database

Review of attachment 8685290 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks!
Attachment #8685290 - Flags: review?(alwu) → review+
https://hg.mozilla.org/mozilla-central/rev/7ae90a04b0fd
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S11 (13Nov)
This bug has been verified as "pass" on the latest build of Flame KK 2.5&2.6 and Aires KK 2.6 by the STR in comment 0.

Actual results: After changing the volume and rebooting, the volume level is the same as before reboot.
See attachment: verified_Aries_v2.6.3gp
Reproduce rate: 0/15


Device: Flame KK v2.6 512mb (master)(Pass)
Build ID               20151112150206
Gaia Revision          27bc9412ca607648bc398b25bb1ae25653b2b278
Gaia Date              2015-11-12 02:27:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151112.183236
Firmware Date          Thu Nov 12 18:32:49 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.6 (master)(Pass)
Build ID               20151112120735
Gaia Revision          27bc9412ca607648bc398b25bb1ae25653b2b278
Gaia Date              2015-11-12 02:27:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3cc3b1968524248450c465c4ea2ee5596ffa65f2
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151112.112635
Firmware Date          Thu Nov 12 11:26:43 UTC 2015
Bootloader             s1
You need to log in before you can comment on or make changes to this bug.