Reader View: Poor Scrolling on Final Page

RESOLVED WONTFIX

Status

()

Toolkit
Reader Mode
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Sean Ryan, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

In Reader View, press Page Down key until reaching the final (last) page.


Actual results:

Each page correctly advanced by showing the last line of the current page as the first line of the new page, except for the final page where the last line of the previous page appears in the middle of the screen.


Expected results:

All screens should advance one full page when pressing Page Down including on the final page. The current behaviour appears to be to fill the screen on the final page by positioning the last line at the bottom of the screen, which results in a chunk of the previous page showing. This makes it difficult for one to read when the eye is trained to look at the top of the screen after pressing Page Down.

I expect that the final page should correctly flow from the previous page, and that the last screen will likely always be partially filled with text followed by blank space on the rest of the screen below. Not only will this improve readability, but it will give a useful indication that the end of the document has been reached (though an actual line / message at the end would also be helpful because if the last page was almost entirely full, one would always have to press Page Down once again to be sure you're reached the end of the document).

Updated

3 years ago
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

Updated

2 years ago
Duplicate of this bug: 1184134

Comment 2

2 years ago
I'm sorry for the delay in response. I don't think I understand what you're asking for.

Reader mode effectively just presents another webpage. The webpage's length is determined by how big the area of text on the screen is, plus some whitespace at the bottom.

As far as I can tell, what you're saying is that if you start to read at the top of the page, and use 'page down' to go down one page of text at a time, you want there to always be enough space for what was previously at the bottom to end up at the top.

This is difficult because, in reader mode:

1) the size of the text is configurable
2) the size of the area in which we show text is configurable (as of Firefox 49, now 'developer edition', to be released in a few months)
3) the position at which you are reading is not just influenced by your 'page down' presses but also by e.g. mouse scrolls, anchor navigation (clicking in-page links), etc.
4) having too much space at the bottom would mean you could end up looking at only empty space instead of text, which also doesn't seem to make sense.

Finally, if we did this the scroll bar length and position would always imply there was more text underneath the content you were already looking at, even if there was only empty space, which is equally wrong / counterintuitive.

Am I just misunderstanding your request? How do you think this should be fixed?
Flags: needinfo?(s1r1ag-bugzilla)
(Reporter)

Comment 3

2 years ago
I'm asking simply that when you press 'Page Down', the display will advance 1 whole page - always, including on the final page.
Flags: needinfo?(s1r1ag-bugzilla)

Comment 4

2 years ago
(In reply to Sean Ryan from comment #3)
> I'm asking simply that when you press 'Page Down', the display will advance
> 1 whole page - always, including on the final page.

OK. In that case, I don't think we will implement this, because what you're asking for is (a) really complicated and requiring a lot of code to implement; (b) likely won't be possible to do perfectly predictably and (c) will break other usecases (such as expecting scrollbars to give you an accurate view of how much of a page is left).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.