If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
Networking
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: sicking, Unassigned)

Tracking

({addon-compat})

unspecified
mozilla45
addon-compat
Points:
---

Firefox Tracking Flags

(firefox45 fixed)

Details

Attachments

(1 attachment)

Created attachment 8684690 [details] [diff] [review]
Patch to fix

It doesn't seem to be used. There hasn't been any "real" changes to this code since we migrated to hg. All changes are global changes that happened to touch urichecker.cpp/h as well.

http://mxr.mozilla.org/mozilla-central/search?string=urichecker

The only risk here is that addons might use it. If that's the case we can always put it back.
Attachment #8684690 - Flags: review?(mcmanus)
Comment on attachment 8684690 [details] [diff] [review]
Patch to fix

thanks
Attachment #8684690 - Flags: review?(mcmanus) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/a5d633bb299c73ae5341550453798e82536fce30
Bug 1222829: Remove URIChecker. r=mcmanus

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a5d633bb299c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Duplicate of this bug: 844214

Comment 5

a year ago
Is there a way of checking for valid links other than using the removed code?
https://dxr.mozilla.org/comm-central/search?q=urichecker&redirect=false
Flags: needinfo?(mcmanus)
Flags: needinfo?(mcmanus) → needinfo?(valentin.gosu)
(In reply to Ian Neal from comment #5)
> Is there a way of checking for valid links other than using the removed code?
> https://dxr.mozilla.org/comm-central/search?q=urichecker&redirect=false

If by valid links you mean valid URLs, I think creating a URL and seeing if the result is NS_OK should work.
I think calling NS_NewURI is the preferred way of creating a URL. If you need it to be a URL (instead of a URI) check if the result QIs to nsIStandardURL.

If you want to check if the link is loadable, you can do something similar to what the code used to do - open a channel to the URL and see if it loads.
Flags: needinfo?(valentin.gosu)
You need to log in before you can comment on or make changes to this bug.