[NFC]NFC tag can't be correctly identified by phone.

RESOLVED DUPLICATE of bug 1136512

Status

Firefox OS
NFC
RESOLVED DUPLICATE of bug 1136512
2 years ago
2 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Assigned: tnguyen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(8 attachments)

(Reporter)

Description

2 years ago
Created attachment 8685366 [details]
Arieskk_video.3gp

[1.Description]:
[AriesKK][NFC]Device can't identify the type 1,4 nfc tag when device is close to them, device has no response. If device is close to type 2,3 (Felica) tag, device just shakes but can't get the correct information.
Found time:04:12
See attachment:logcat_0412.txt & Arieskk_video.3gp

[2.Testing Steps]: 
Prerequesite:Flash customize ROM from https://goo.gl/I64uqa,modify system/etc/libnfc-nxp.conf and reboot phone, disconnect to pc, and install "NFC API tests" app.

1. Enable NFC 
2. Launch NFC test app, and open to "NFC Read Tag" 
3. Tap tag(type 1,4) on device.
4. Tap tag(type 2,3) on device.

[3.Expected Result]: 
Step 3&4. Tag information should show correctly on app.

[4.Actual Result]: 
3. Device has no response.
4. Device gets the inaccurate information.

[5.Reproduction build]: 
Arieskk v2.6 (Affected)
Build ID               20151103111445
Gaia Revision          519d03420e2d9e9ff2924ea04fba584e47a1756c
Gaia Date              2015-11-02 10:28:51
Gecko Revision         n/a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.tnguyen.20151102.185240
Firmware Date          mon Nov  2 18:52:46 CST 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12909

[8. Note]:
If user connect device and pc,NFC function will works normal.
Nightly build is unaffected.
(Reporter)

Comment 1

2 years ago
Created attachment 8685367 [details]
logcat_0412.txt
(Assignee)

Comment 2

2 years ago
Could you please:
- Provide separated log of each issue (type 1, 2 ,3 ,4 issue)?
- Make sure you put the tag not too close and not too far from your device. Sometimes if you put the tag too close or too far, it's a bit hard to detect the tag.
- Please compare your tag read information of customized build with master build (not with other app or device's result). I see sometimes we receive "null" information with master build with particular tag
Thanks
(Assignee)

Comment 3

2 years ago
The purpose of the test is to compare custom build and master build and find regression bugs.
If the issue occurs in master build, it should not be listed here (should open new issue related to master build). So, please compare test result between 2 builds to see if there's any difference.
Thanks
Flags: needinfo?(xiongfuchao)
(Reporter)

Comment 4

2 years ago
Created attachment 8685798 [details]
Conpare_master_custom.png

Hi Thomas,
Thanks for you checking. Here is my check result of your questions.
1. Sepearted log of each issue are provided ,please see log Tag1_2203.txt,Tag2_2207.txt,Tag3_2213.txt,Tag4_2214.txt.
2. This bug does not depend on distance between device and tag,I tried variety of position but device can't detect tag(type 1,2,4) or very hard to detect the tag,after connect device and pc,device can detect tag easily. see compare_plug_unplug.3gp
3. For my tag read information, please see attachment Conpare_master_custom.png
4. This issue just exeist on my tested build(customized build), and it does not exist on master build.
Flags: needinfo?(xiongfuchao)
(Reporter)

Comment 5

2 years ago
Created attachment 8685799 [details]
compare_plug_unplug.3gp
(Reporter)

Comment 6

2 years ago
Created attachment 8685800 [details]
Tag1_2203.txt
(Reporter)

Comment 7

2 years ago
Created attachment 8685801 [details]
Tag2_2207.txt
(Reporter)

Comment 8

2 years ago
Created attachment 8685802 [details]
Tag3_2213.txt
(Reporter)

Comment 9

2 years ago
Created attachment 8685803 [details]
Tag4_2214.txt
(Assignee)

Comment 10

2 years ago
Thanks for your great finding.
- I found that I have to add a kernel config to enable power management clock request handling. (it will fix the odd unplugged usb behavior)
- Looking at your Conpare_master_custom.png and using ASCII to decode hex to text, I got result:

+ Tag1 master and Tag1 custom build : exactly the same ( except isLost because you moved your tag)
+ Tag2 master build Payload : 0x0, 0x68, 0x74, 0x74, 0x70, 0x03,..... --> http://google.com
Custom build Payload: 0x4, 0x77, 0x77, 0x77,.... --> www.yahoo.co

+ Tag3 master build payload: http://google.com
Tag 3 custom build payload: tnf : media-type, Type : text/x-vcard, Payload: BEGIN:VCARD\nVERSION....

+ Tag4 master build payload: http://google.com
Tag 4 custom build payload: tnf : media-type, Type : text/x-vcard, Payload: BEGIN:VCARD\nVERSION....

I think that you are using different tags, please make sure you use the same tag to compare. 
I will provide a new build fixed "unplugged usb behavior" and will keep you posted.
Thanks
(Reporter)

Updated

2 years ago
QA Whiteboard: [MGSEI-Triage+]
(Assignee)

Updated

2 years ago
Assignee: nobody → tnguyen
Depends on: 1136512
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136512
You need to log in before you can comment on or make changes to this bug.