Saving files to disk modifies their contents

VERIFIED DUPLICATE of bug 116008

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 116008
16 years ago
13 years ago

People

(Reporter: Gili, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.7+) Gecko/20020122
BuildID:    2002012216

Mozilla should never modify files without the user's permission.

When saving files to disk you may choose to remap URLs on the user's behalf (as
mentioned in the repro steps) but you must ask for his permission. If he
disagrees, you must continue saving to disk without remapping URLs (ie: don't
simply abort).

I assume this URL remapping was done for the sake of home-users who want to
download HTML files to disk and view them locally, however this wrecks a lot of
havok for those of us running servers on our systems. We _have_ the correct
setup on the client's end to be able to view the page and don't need/want the
URLs remapped.

Reproducible: Always
Steps to Reproduce:
1. Visit specified URL
2. Save page to disk
3. Notice how the link to "separator.gif" is moved from "/separator.gif" to
"/faq_files/separator.gif" in the html code
This is needed for saving complete HTML pages without breaking href. Try using
'Web Page, HTML only' mode. (It won't save images, just the HTML file) 

INVALID?

Comment 2

16 years ago
i would agree that this is an invalid,
except a bug relating to this has been filed, which if fixed, would fix this
issue...

*** This bug has been marked as a duplicate of 116008 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
reassign in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.