SVG image not color filled

RESOLVED DUPLICATE of bug 841920

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 841920
2 years ago
2 years ago

People

(Reporter: Philippe Steinthal, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Steps to reproduce:

<html>
<script>
function load() {
	var svg='<svg xmlns:xlink="http://www.w3.org/1999/xlink" xmlns="http://www.w3.org/2000/svg" overflow="hidden" width="27" height="27"><defs><radialGradient id="dojoxUnique1" gradientUnits="userSpaceOnUse" cx="13.50000000" cy="13.50000000" r="12.50000000"><stop offset="0.00000000" stop-color="rgb(255, 0, 0)" stop-opacity="1"/><stop offset="1.00000000" stop-color="rgb(255, 0, 0)" stop-opacity="1"/></radialGradient><radialGradient id="dojoxUnique2" gradientUnits="userSpaceOnUse" cx="13.50000000" cy="13.50000000" r="12.50000000"><stop offset="0.00000000" stop-color="rgb(0, 128, 0)" stop-opacity="1"/><stop offset="1.00000000" stop-color="rgb(0, 128, 0)" stop-opacity="1"/></radialGradient><radialGradient id="dojoxUnique3" gradientUnits="userSpaceOnUse" cx="13.50000000" cy="13.50000000" r="12.50000000"><stop offset="0.00000000" stop-color="rgb(0, 0, 255)" stop-opacity="1"/><stop offset="1.00000000" stop-color="rgb(0, 0, 255)" stop-opacity="1"/></radialGradient></defs><rect fill="rgb(0, 0, 0)" fill-opacity="0" stroke="none" stroke-opacity="0" stroke-width="1" stroke-linecap="butt" stroke-linejoin="miter" stroke-miterlimit="4" x="0" y="0" width="28" height="28" ry="0" rx="0" fill-rule="evenodd"/><rect fill="none" fill-opacity="0" stroke="rgb(0, 0, 0)" stroke-opacity="0" stroke-width="1" stroke-linecap="butt" stroke-linejoin="miter" stroke-miterlimit="4" x="0" y="0" width="26" height="26" ry="0" rx="0" stroke-dasharray="none" /><rect fill="rgb(0, 0, 0)" fill-opacity="0" stroke="none" stroke-opacity="0" stroke-width="1" stroke-linecap="butt" stroke-linejoin="miter" stroke-miterlimit="4" x="9" y="9" width="9" height="9" ry="0" rx="0" fill-rule="evenodd"/><g><path fill="url(#dojoxUnique1)" stroke="rgb(255, 255, 255)" stroke-opacity="1" stroke-width="1.5" stroke-linecap="butt" stroke-linejoin="miter" stroke-miterlimit="4" path="" d="M 13.5 13.5L 26 13.5A 12.5 12.5 0 0 1 3.8686 21.4678L 13.5 13.5Z" stroke-dasharray="none"  fill-rule="evenodd"/><path fill="url(#dojoxUnique2)" stroke="rgb(255, 255, 255)" stroke-opacity="1" stroke-width="1.5" stroke-linecap="butt" stroke-linejoin="miter" stroke-miterlimit="4" path="" d="M 13.5 13.5L 3.8686 21.4678A 12.5 12.5 0 0 1 9.2658 1.7390L 13.5 13.5Z" stroke-dasharray="none"  fill-rule="evenodd"/><path fill="url(#dojoxUnique3)" stroke="rgb(255, 255, 255)" stroke-opacity="1" stroke-width="1.5" stroke-linecap="butt" stroke-linejoin="miter" stroke-miterlimit="4" path="" d="M 13.5 13.5L 9.2658 1.7390A 12.5 12.5 0 0 1 26 13.5000L 13.5 13.5Z" stroke-dasharray="none"  fill-rule="evenodd"/></g></svg>';
	var svgBlob = new Blob([svg], { type: "image/svg+xml;charset=utf-8" });
	var url = window.URL.createObjectURL(svgBlob);
	var img = document.createElement("img");
	img.src = url;
	var src = document.getElementById("imagediv");
	src.appendChild(img);
}
</script>
<body bgcolor="black" onload="load()">
<div id="imagediv">
</div>
</body>
</html>


Actual results:

Not color filled (workd on chrome and ie)


Expected results:

Pie filled with green red and blue sections
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → SVG
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 841920
You need to log in before you can comment on or make changes to this bug.