CSS element type selector does not match SVG symbol element

RESOLVED DUPLICATE of bug 265894

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 265894
2 years ago
2 months ago

People

(Reporter: Yonathan Randolph, Unassigned)

Tracking

41 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8685753 [details]
css-symbol-selector-test.svg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2547.0 Safari/537.36

Steps to reproduce:

View an SVG document containing a symbol that is styled by a statement whose selector contains the type selector “symbol”.

Usually, you only want to style a symbol in order to override the default clipping caused by overflow: clip in the user-agent style sheet[1].

[1] http://www.w3.org/TR/SVG/styling.html#UAStyleSheet


Actual results:

The CSS rule “overflow: visible” did not apply to the symbol matched by the type selector “symbol”.


Expected results:

The CSS rule “overflow: visible” should apply to the symbol matched by the type selector “symbol”.

This is a fairly minor bug since the selector “#square” works even though “symbol#square” doesn’t.

Updated

2 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265894
I don't think this is a straightforward duplicate; I think it's different.  (More related to bug 1268431, but not the same.)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Depends on: 1268431
Blocks: 237020
Depends on: 265894

Comment 3

2 months ago
Since I will fix cloned symbol element as svg element problem in bug 265894. mark this one as a dup
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265894
You need to log in before you can comment on or make changes to this bug.